summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2008-05-14 11:40:18 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2008-05-14 11:40:18 -0700
commit216b27c681dfacba194c9f001eec6287008a750c (patch)
tree66a673a895ddb57ed2a73322995cdbf40f2f6b10 /Makefile.am
parent17cd83259313b16a0ef27bf94a09612be8fece96 (diff)
downloadvyatta-cfg-qos-216b27c681dfacba194c9f001eec6287008a750c.tar.gz
vyatta-cfg-qos-216b27c681dfacba194c9f001eec6287008a750c.zip
new qos-policy type rate-limit
Add new QoS policy type "rate-limit" which is a wrapper around the the Token Bucket Filter (TBF) qdisc. Rate limit provides a simple way to do basic bandwidth limitation without the complexity of the doing multiple classes in the traffic shaper policy.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 54c5031..23e2bfa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,6 +10,7 @@ sbin_SCRIPTS += scripts/vyatta-qos-util.pl
share_perl5_DATA += scripts/VyattaQosUtil.pm
share_perl5_DATA += scripts/VyattaQosFairQueue.pm
share_perl5_DATA += scripts/VyattaQosTrafficShaper.pm
+share_perl5_DATA += scripts/VyattaQosRateLimiter.pm
share_perl5_DATA += scripts/VyattaQosMatch.pm
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \