summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--templates/interfaces/ethernet/node.tag/qos-policy/node.def2
-rw-r--r--templates/interfaces/ethernet/node.tag/qos-policy/out/node.def6
-rw-r--r--templates/qos-policy/fair-queue/node.def4
-rw-r--r--templates/qos-policy/fair-queue/node.tag/description/node.def2
-rw-r--r--templates/qos-policy/fair-queue/node.tag/hash-interval/node.def2
-rw-r--r--templates/qos-policy/fair-queue/node.tag/queue-limit/node.def2
-rw-r--r--templates/qos-policy/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def6
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/description/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/description/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/interface/node.def14
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/address/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/port/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dsfield/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/address/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/port/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/vif/node.def8
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/priority/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/queue/node.def12
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/rate/node.def16
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def6
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/priority/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/queue/node.def12
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/rate/node.def16
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/description/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/rate/node.def16
34 files changed, 93 insertions, 91 deletions
diff --git a/.gitignore b/.gitignore
index 3f43d67..dbebe75 100644
--- a/.gitignore
+++ b/.gitignore
@@ -11,6 +11,8 @@
/config.sub
/configure
/debian/files
+/debian/vyatta-cfg-qos.postinst
+/debian/vyatta-cfg-qos
/INSTALL
/Makefile.in
/Makefile
diff --git a/templates/interfaces/ethernet/node.tag/qos-policy/node.def b/templates/interfaces/ethernet/node.tag/qos-policy/node.def
index b4ab8d8..2c0cf7a 100644
--- a/templates/interfaces/ethernet/node.tag/qos-policy/node.def
+++ b/templates/interfaces/ethernet/node.tag/qos-policy/node.def
@@ -1 +1 @@
-help: "Configure qos-policy"
+help: Configure qos-policy
diff --git a/templates/interfaces/ethernet/node.tag/qos-policy/out/node.def b/templates/interfaces/ethernet/node.tag/qos-policy/out/node.def
index bb9ea38..6efaf03 100644
--- a/templates/interfaces/ethernet/node.tag/qos-policy/out/node.def
+++ b/templates/interfaces/ethernet/node.tag/qos-policy/out/node.def
@@ -1,4 +1,4 @@
type: txt
-help: "Set outbound QOS policy"
-update: "sudo /opt/vyatta/sbin/vyatta-qos.pl --update $(../../@) out $(@)"
-delete: "sudo /opt/vyatta/sbin/vyatta-qos.pl --delete $(../../@) out"
+help: Set outbound QOS policy
+update:expression: "sudo /opt/vyatta/sbin/vyatta-qos.pl --update $VAR(../../@) out $VAR(@)"
+delete:expression: "sudo /opt/vyatta/sbin/vyatta-qos.pl --delete $VAR(../../@) out"
diff --git a/templates/qos-policy/fair-queue/node.def b/templates/qos-policy/fair-queue/node.def
index 36f3a35..304e0d4 100644
--- a/templates/qos-policy/fair-queue/node.def
+++ b/templates/qos-policy/fair-queue/node.def
@@ -1,4 +1,4 @@
tag:
type: txt
-syntax: pattern $(@) "^[^-]" ; "Qos queue name cannot start with \"-\""
-help: "Configure fair queueing based policy"
+syntax:expression: pattern $VAR(@) "^[^-]" ; "Qos queue name cannot start with \"-\""
+help: Configure fair queueing based policy
diff --git a/templates/qos-policy/fair-queue/node.tag/description/node.def b/templates/qos-policy/fair-queue/node.tag/description/node.def
index 335eb7e..1da9e34 100644
--- a/templates/qos-policy/fair-queue/node.tag/description/node.def
+++ b/templates/qos-policy/fair-queue/node.tag/description/node.def
@@ -1,2 +1,2 @@
type: txt
-help: "Description for this queuing policy"
+help: Description for this queuing policy
diff --git a/templates/qos-policy/fair-queue/node.tag/hash-interval/node.def b/templates/qos-policy/fair-queue/node.tag/hash-interval/node.def
index de3d6a0..60d6255 100644
--- a/templates/qos-policy/fair-queue/node.tag/hash-interval/node.def
+++ b/templates/qos-policy/fair-queue/node.tag/hash-interval/node.def
@@ -1,3 +1,3 @@
type: u32
default: 0
-help: "Rehash interval (seconds)"
+help: Rehash interval (seconds)
diff --git a/templates/qos-policy/fair-queue/node.tag/queue-limit/node.def b/templates/qos-policy/fair-queue/node.tag/queue-limit/node.def
index e6456f8..4275b7b 100644
--- a/templates/qos-policy/fair-queue/node.tag/queue-limit/node.def
+++ b/templates/qos-policy/fair-queue/node.tag/queue-limit/node.def
@@ -1,2 +1,2 @@
type: u32
-help: "Maximum queue size (packets)"
+help: Maximum queue size (packets)
diff --git a/templates/qos-policy/node.def b/templates/qos-policy/node.def
index 9e04559..1bd41ac 100644
--- a/templates/qos-policy/node.def
+++ b/templates/qos-policy/node.def
@@ -1 +1 @@
-help: "Qos policy type"
+help: Qos policy type
diff --git a/templates/qos-policy/traffic-shaper/node.def b/templates/qos-policy/traffic-shaper/node.def
index 3d623b7..38d72d2 100644
--- a/templates/qos-policy/traffic-shaper/node.def
+++ b/templates/qos-policy/traffic-shaper/node.def
@@ -1,4 +1,4 @@
tag:
type: txt
-syntax: pattern $(@) "^[^-]" ; "Qos queue name cannot start with \"-\""
-help: "Configure traffic shaping based policy"
+syntax:expression: pattern $VAR(@) "^[^-]" ; "Qos queue name cannot start with \"-\""
+help: Configure traffic shaping based policy
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.def
index a9944bd..682fd6c 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.def
@@ -1,4 +1,4 @@
tag:
type: u32
-help: "Configure class handle"
-syntax: ($(@) > 1 && $(@) < 65536) ; "$(@) handle must be between 2 and 65535"
+help: Configure class handle
+syntax:expression: ($VAR(@) > 1 && $VAR(@) < 65536) ; "$VAR(@) handle must be between 2 and 65535"
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def
index d32af54..f6b4dd7 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def
@@ -1,3 +1,3 @@
type: txt
-help: "Set the burst size for this class"
-syntax: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$(@)\""
+help: Set the burst size for this class
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$VAR(@)\""
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def
index ad78fa2..a82414a 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def
@@ -1,4 +1,4 @@
type: txt
-help: "Set the limit for this class"
-syntax: exec "[[ \"$(@)\" =~ \"[0-9]+(\.[0-9]*)?%\" ]] || \
- /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$(@)\""
+help: Set the limit for this class
+syntax:expression: exec "[[ \"$VAR(@)\" =~ \"[0-9]+(\.[0-9]*)?%\" ]] || \
+ /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/description/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/description/node.def
index f632aa0..9a24868 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/description/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/description/node.def
@@ -1,2 +1,2 @@
type: txt
-help: "Description for this traffic class"
+help: Description for this traffic class
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.def
index 6b77136..f5235a8 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.def
@@ -1,4 +1,4 @@
tag:
type: txt
-syntax: pattern $(@) "^[^-]" ; "Match queue name cannot start with \"-\""
-help: "Configure class matching rule name"
+syntax:expression: pattern $VAR(@) "^[^-]" ; "Match queue name cannot start with \"-\""
+help: Configure class matching rule name
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/description/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/description/node.def
index e62ed79..903f260 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/description/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/description/node.def
@@ -1,2 +1,2 @@
type: txt
-help: "Description for this match"
+help: Description for this match
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/interface/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/interface/node.def
index fa8f1cb..fe7933c 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/interface/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/interface/node.def
@@ -1,11 +1,11 @@
tag:
type: txt
-help: "Ethernet interface name"
-syntax: exec " \
- if [ -z \"`ip link | egrep -v 'eth[0-9]+[.]' | grep $(@)`\" ]; then \
- echo Invalid ethernet interface [$(@)]; \
+help: Ethernet interface name
+syntax:expression: exec " \
+ if [ -z \"`ip link | egrep -v 'eth[0-9]+[.]' | grep $VAR(@)`\" ]; then \
+ echo Invalid ethernet interface [$VAR(@)]; \
exit 1 ; \
fi ; "
-#allowed: local -a array ;
-# array=( /sys/class/net/{eth,vmnet}[0-9]+[^.] ) ;
-# echo -n ${array[@]##*/}
+allowed: local -a array ;
+ array=( /sys/class/net/{eth,vmnet}[0-9]+[^.] ) ;
+ echo -n ${array[@]##*/}
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/address/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/address/node.def
index 95087be..92ecc65 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/address/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/address/node.def
@@ -1,2 +1,2 @@
type: ipv4net
-help: "Match IP destination address"
+help: Match IP destination address
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/port/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/port/node.def
index a082a37..3af9e53 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/port/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/destination/port/node.def
@@ -1,3 +1,3 @@
type: u32
-help: "Match IP destination port"
-syntax: ($(@) > 0 && $(@) < 65536) ; "port must be between 1 and 65535"
+help: Match IP destination port
+syntax:expression: ($VAR(@) > 0 && $VAR(@) < 65536) ; "port must be between 1 and 65535"
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dsfield/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dsfield/node.def
index 4a9e22e..38160f7 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dsfield/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dsfield/node.def
@@ -1,3 +1,3 @@
type: txt
-help: "Match dsfield/TOS: either hexadecimal number (0x10) or identifier"
-syntax: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dsfield \"$(@)\""
+help: Match dsfield/TOS: either hexadecimal number (0x10) or identifier
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dsfield \"$VAR(@)\""
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
index 5681770..8eb9dbb 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
@@ -1,3 +1,3 @@
type: txt
-help: "Match IP protocol name or number"
-syntax: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol \"$(@)\""
+help: Match IP protocol name or number
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol \"$VAR(@)\""
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/address/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/address/node.def
index e20679d..14d7e6b 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/address/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/address/node.def
@@ -1,2 +1,2 @@
type: ipv4net
-help: "Match IP source address"
+help: Match IP source address
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/port/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/port/node.def
index c0af33f..1ca4940 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/port/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/source/port/node.def
@@ -1,3 +1,3 @@
type: u32
-help: "Match IP source port"
-syntax: ($(@) > 0 && $(@) < 65536) ; "port must be between 1 and 65535"
+help: Match IP source port
+syntax:expression: ($VAR(@) > 0 && $VAR(@) < 65536) ; "port must be between 1 and 65535"
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/vif/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/vif/node.def
index 3de7d2f..358ba5b 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/vif/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/vif/node.def
@@ -1,6 +1,6 @@
tag:
type: u32
-help: "VLAN ID"
-syntax: $(@) >= 0 && $(@) <= 4095; "VLAN ID must be between 0 and 4095"
-#comp_help: possible completions:
-# <0-4095> Set VLAN ID
+help: VLAN ID
+syntax:expression: $VAR(@) >= 0 && $VAR(@) <= 4095; "VLAN ID must be between 0 and 4095"
+comp_help: possible completions:
+ <0-4095> Set VLAN ID
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/priority/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/priority/node.def
index 72b36e2..a2dd238 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/priority/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/priority/node.def
@@ -1,4 +1,4 @@
type: u32
default: 1
-help: "Priority for usage of extra bandwidth"
-syntax: ($(@) > 0 && $(@) < 10) ; "priority must be between 1 and 10"
+help: Priority for usage of extra bandwidth
+syntax:expression: ($VAR(@) > 0 && $VAR(@) < 10) ; "priority must be between 1 and 10"
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/queue/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/queue/node.def
index a18ecc1..bfe4544 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/queue/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/queue/node.def
@@ -1,8 +1,8 @@
type: txt
default: "SFQ"
-syntax: $(@) in "SFQ", "FIFO", "RED"; "Queue must be SFQ, FIFO, or RED"
-help: "Set the queue type for this class"
-#comp_help:Possible completions:
-# FIFO Use FIFO queue
-# RED Random Exponential Drop - TCP friendly behaviour
-# SFQ Use Stochastic Fair Queue - fairness by flow (default)
+syntax:expression: $VAR(@) in "SFQ", "FIFO", "RED"; "Queue must be SFQ, FIFO, or RED"
+help: Set the queue type for this class
+comp_help:Possible completions:
+ FIFO Use FIFO queue
+ RED Random Exponential Drop - TCP friendly behaviour
+ SFQ Use Stochastic Fair Queue - fairness by flow (default)
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/rate/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/rate/node.def
index 9f9721a..35d7b1d 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/rate/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/rate/node.def
@@ -1,11 +1,11 @@
type: txt
default: "100%"
-help: "Set the base rate for this class"
-syntax: exec "[[ \"$(@)\" =~ \"[0-9]+(\.[0-9]*)?%\" ]] || \
- /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$(@)\""
-#comp_help: Allowed values:
-# <number>% Percentage of overall rate (default 100%)
-# <number><suffix> Bitrate with scaling suffix
-# bits per sec (kbit, mbit, gbit)
-# bytes per sec (kbps, mbps, gbps)
+help: Set the base rate for this class
+syntax:expression: exec "[[ \"$VAR(@)\" =~ \"[0-9]+(\.[0-9]*)?%\" ]] || \
+ /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
+comp_help: Allowed values:
+ <number>% Percentage of overall rate (default 100%)
+ <number><suffix> Bitrate with scaling suffix
+ bits per sec (kbit, mbit, gbit)
+ bytes per sec (kbps, mbps, gbps)
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def
index 8360670..6fb0187 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def
@@ -1,4 +1,4 @@
type: txt
-help: "Set the burst size for default traffic"
+help: Set the burst size for default traffic
default: "15k"
-syntax: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$VAR(@)\""
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def
index 7c501b3..dff4a89 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def
@@ -1,6 +1,6 @@
type: txt
-help: "Set the limit for default traffic"
+help: Set the limit for default traffic
default: "100%"
-syntax: exec "[[ \"$(@)\" =~ \"[0-9]+(\.[0-9]*)?%\" ]] || \
- /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$(@)\""
+syntax:expression: exec "[[ \"$VAR(@)\" =~ \"[0-9]+(\.[0-9]*)?%\" ]] || \
+ /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/node.def
index f5adce3..8d05de8 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/node.def
@@ -1 +1 @@
-help: "Configure default policy"
+help: Configure default policy
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/priority/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/priority/node.def
index ad6b9aa..b22c6e1 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/priority/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/priority/node.def
@@ -1,4 +1,4 @@
type: u32
default: 8
-help: "Priority for usage of extra bandwidth"
-syntax: ($(@) > 0 && $(@) < 10) ; "priority must be between 1 and 10"
+help: Priority for usage of extra bandwidth
+syntax:expression: ($VAR(@) > 0 && $VAR(@) < 10) ; "priority must be between 1 and 10"
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/queue/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/queue/node.def
index a18ecc1..bfe4544 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/queue/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/queue/node.def
@@ -1,8 +1,8 @@
type: txt
default: "SFQ"
-syntax: $(@) in "SFQ", "FIFO", "RED"; "Queue must be SFQ, FIFO, or RED"
-help: "Set the queue type for this class"
-#comp_help:Possible completions:
-# FIFO Use FIFO queue
-# RED Random Exponential Drop - TCP friendly behaviour
-# SFQ Use Stochastic Fair Queue - fairness by flow (default)
+syntax:expression: $VAR(@) in "SFQ", "FIFO", "RED"; "Queue must be SFQ, FIFO, or RED"
+help: Set the queue type for this class
+comp_help:Possible completions:
+ FIFO Use FIFO queue
+ RED Random Exponential Drop - TCP friendly behaviour
+ SFQ Use Stochastic Fair Queue - fairness by flow (default)
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/rate/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/rate/node.def
index b12c6b6..9463038 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/rate/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/rate/node.def
@@ -1,11 +1,11 @@
type: txt
default: "50%"
-help: "Set the rate for default traffic"
-syntax: exec "[[ \"$(@)\" =~ \"[0-9]+(\.[0-9]*)?%\" ]] || \
- /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$(@)\""
-#comp_help: Allowed values:
-# <number>% Percentage of overall rate (default 50%)
-# <number><suffix> Bitrate with scaling suffix
-# bits per sec (kbit, mbit, gbit)
-# bytes per sec (kbps, mbps, gbps)
+help: Set the rate for default traffic
+syntax:expression: exec "[[ \"$VAR(@)\" =~ \"[0-9]+(\.[0-9]*)?%\" ]] || \
+ /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
+comp_help: Allowed values:
+ <number>% Percentage of overall rate (default 50%)
+ <number><suffix> Bitrate with scaling suffix
+ bits per sec (kbit, mbit, gbit)
+ bytes per sec (kbps, mbps, gbps)
diff --git a/templates/qos-policy/traffic-shaper/node.tag/description/node.def b/templates/qos-policy/traffic-shaper/node.tag/description/node.def
index 335eb7e..1da9e34 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/description/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/description/node.def
@@ -1,2 +1,2 @@
type: txt
-help: "Description for this queuing policy"
+help: Description for this queuing policy
diff --git a/templates/qos-policy/traffic-shaper/node.tag/rate/node.def b/templates/qos-policy/traffic-shaper/node.tag/rate/node.def
index 22d54b5..1dc02ad 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/rate/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/rate/node.def
@@ -1,10 +1,10 @@
type: txt
-help: "Set the base rate for this policy"
+help: Set the base rate for this policy
default: "auto"
-syntax: exec "[[ \"$(@)\" == \"auto\" ]] || \
- /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$(@)\""
-#comp_help: Allowed values:
-# auto Set rate based on interface speed (default)
-# <number><suffix> Bitrate with scaling suffix
-# bits per sec (kbit, mbit, gbit)
-# bytes per sec (kbps, mbps, gbps)
+syntax:expression: exec "[[ \"$VAR(@)\" == \"auto\" ]] || \
+ /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
+comp_help: Allowed values:
+ auto Set rate based on interface speed (default)
+ <number><suffix> Bitrate with scaling suffix
+ bits per sec (kbit, mbit, gbit)
+ bytes per sec (kbps, mbps, gbps)