summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 7 insertions, 15 deletions
diff --git a/debian/rules b/debian/rules
index ccbee71..df2609a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,10 +14,7 @@
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-PACKAGE=vyatta-cfg-qos
-PKGDIR=$(CURDIR)/debian/$(PACKAGE)
-
-CFLAGS = -Wall -g
+PKGDIR=$(CURDIR)/debian/tmp
configure = ./configure
configure += --host=$(DEB_HOST_GNU_TYPE)
@@ -25,14 +22,6 @@ configure += --build=$(DEB_BUILD_GNU_TYPE)
configure += --prefix=/opt/vyatta
configure += --mandir=\$${prefix}/share/man
configure += --infodir=\$${prefix}/share/info
-configure += CFLAGS="$(CFLAGS)"
-configure += LDFLAGS="-Wl,-z,defs"
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
configure: configure.ac Makefile.am
chmod +x debian/autogen.sh
@@ -72,8 +61,11 @@ install: build
$(MAKE) DESTDIR=$(PKGDIR) install
- install -D --mode=0644 debian/lintian $(PKGDIR)/usr/share/lintian/overrides/$(PACKAGE)
- install -D --mode=0644 debian/linda $(PKGDIR)/usr/share/linda/overrides/$(PACKAGE)
+ for p in vyatta-cfg-qos vyatta-cfg-qos-serial; do \
+ install -D --mode=0644 debian/$$p.lintian-overrides \
+ debian/$$p/usr/share/lintian/overrides/$$p; \
+ done
+
# Build architecture-independent files here.
binary-indep: build install
@@ -82,7 +74,7 @@ binary-indep: build install
dh_testroot
dh_installchangelogs ChangeLog
dh_installdocs
- dh_install
+ dh_install --sourcedir=debian/tmp
dh_installdebconf
dh_link
dh_strip