summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrbalocca <rbalocca@vyatta.com>2008-04-21 16:31:29 -0700
committerrbalocca <rbalocca@vyatta.com>2008-04-21 16:31:29 -0700
commit8328b5607db0e3e8c7cc0cd2ad035475e3dc0887 (patch)
tree680e7a90962bc3a627de58ad79db87af31e9aab4
parentb2fb9963d1b65ac4b32ada1742cd1ba24fa8c739 (diff)
parent69b0e51b4a3afeb6cf1fb8893c3e705412d988b0 (diff)
downloadvyatta-cfg-quagga-8328b5607db0e3e8c7cc0cd2ad035475e3dc0887.tar.gz
vyatta-cfg-quagga-8328b5607db0e3e8c7cc0cd2ad035475e3dc0887.zip
Merge branch 'glendale' into hollywood
Conflicts: templates/interfaces/loopback/node.tag/ip/ospf/network/node.def templates/protocols/bgp/node.tag/parameters/confederation/peers/node.def
-rw-r--r--debian/changelog53
-rw-r--r--scripts/vyatta-linkstatus.pl9
2 files changed, 58 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 543f2f3b..d76656cc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,56 @@
+vyatta-cfg-quagga (0.6) unstable; urgency=low
+
+ VC4.0.2
+ [ Mark O'Brien ]
+
+
+ [ An-Cheng Huang ]
+ * don't signal watchlink if it's not running
+
+ [ Mark O'Brien ]
+
+ -- Mark O'Brien <mobrien@vyatta.com> Sat, 19 Apr 2008 11:56:01 -0700
+
+vyatta-cfg-quagga (0.5) unstable; urgency=low
+
+ VC4.0.2 release candidate
+ [ Mark O'Brien ]
+
+ * Fix for bug 3093
+ * Updated autocomplet for loopback non-broadcast option
+
+ [ Robert Bays ]
+ * fix for bugs 3085,3114,3121,3119,3120
+ * add 2 lines acidentally deleted in last commit for attribute-
+ unchanged
+
+ [ Stig Thormodsrud ]
+ * Fix 3115: set protocols ospf default-information originate always"
+ sends no "always" to the
+ * Fix 3128: "isis" needs to be removed under " protocols ospf access-
+ list <> export"
+ * Fix 3132: "set protocols ospf refresh timers <>" then commit failed
+ * Fix 3133: "delete protocols ospf timers throttle spf delay" commit
+ failed
+ * Fix 3131: "delete protocols ospf parameters abr-type" does not
+ remove " ospf abr-type standard"
+ * Fix 3130: "set protocols ospf compatible rfc1583" or " set protocols
+ ospf parameters
+ * Fix 3124: "set protocols ospf area <> area-type nssa translate
+ always" removed "...... nssa no-summary" from the routing engine
+ * Make sure OSPF area-type is set before default-cost.
+ * Fix 3129: "delete protocols ospf neighbor <> priority" should delete
+ the neighbor in the config as under the routing engine
+ * Fix 3126: ospf virtual-link authentication types should not be able
+ to be coexisted in the config
+ * Fix [Bug 3125] "...... range <> no-advertise" should be removed from
+ the config while it is removed from the routing engine by "set
+ protocols ospf area <> range <> substitute
+
+ [ Mark O'Brien ]
+
+ -- Mark O'Brien <mobrien@vyatta.com> Wed, 16 Apr 2008 09:50:02 -0700
+
vyatta-cfg-quagga (0.4) unstable; urgency=low
3.0.2
diff --git a/scripts/vyatta-linkstatus.pl b/scripts/vyatta-linkstatus.pl
index 25c1adfb..a1381850 100644
--- a/scripts/vyatta-linkstatus.pl
+++ b/scripts/vyatta-linkstatus.pl
@@ -90,7 +90,8 @@ unlink($exclude_lck_file);
#finally kick the process
-open(PID, "< /var/run/vyatta/quagga/watchlink.pid") || die "could not open '/var/run/vyatta/quagga/watchlink.pid'";
-my $foo = <PID>;
-system "kill -10 $foo";
-close(PID);
+if (open(PID, "< /var/run/vyatta/quagga/watchlink.pid")) {
+ my $foo = <PID>;
+ system "kill -10 $foo";
+ close(PID);
+}