diff options
author | Stephen Hemminger <stephen.hemminger@vyatta.com> | 2008-05-21 15:04:49 -0700 |
---|---|---|
committer | Stephen Hemminger <stephen.hemminger@vyatta.com> | 2008-05-21 15:04:49 -0700 |
commit | fa79751880004dd5d8b2cab1e98b1107bc14615e (patch) | |
tree | 2210b1d91b5442b9b84525b3fe057189c435e578 | |
parent | 2d1d83a990dd335fe5f06a7b42020ce4faed5011 (diff) | |
parent | e24d6daf280ed7d51924d0c5e2851c3381556dc4 (diff) | |
download | vyatta-cfg-quagga-fa79751880004dd5d8b2cab1e98b1107bc14615e.tar.gz vyatta-cfg-quagga-fa79751880004dd5d8b2cab1e98b1107bc14615e.zip |
Merge branch 'hollywood' of suva.vyatta.com:/git/vyatta-cfg-quagga into hollywood
-rw-r--r-- | .gitignore | 1 | ||||
-rwxr-xr-x | scripts/policy/vyatta-check-as-prepend.pl | 6 |
2 files changed, 6 insertions, 1 deletions
@@ -11,6 +11,7 @@ /configure /debian/files /debian/vyatta-cfg-quagga +/debian/vyatta-cfg-quagga.debhelper.log /INSTALL /Makefile.in /Makefile diff --git a/scripts/policy/vyatta-check-as-prepend.pl b/scripts/policy/vyatta-check-as-prepend.pl index 0da3d8d6..a34ca0a7 100755 --- a/scripts/policy/vyatta-check-as-prepend.pl +++ b/scripts/policy/vyatta-check-as-prepend.pl @@ -1,6 +1,10 @@ #!/usr/bin/perl @as_list = split(' ',$ARGV[0]); foreach $as (@as_list) { - if ($as =~ /[^\d\s]/ || $as < 1 || $as > 65535) { exit 1;} + if ($as =~ /[^\d\s]/ || $as < 1 || $as > 4294967294) { exit 1;} +} +if (scalar(@as_list) > 24) { + print "Error: max 24 as paths"; + exit 1; } exit 0; |