summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-10-15 10:34:42 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-10-15 10:34:42 -0700
commit5a2647cdb13335b630e692f8b4c1e30ecfc7b8ac (patch)
tree44b59fecd5748de27c0ad32e3de77400381d767e
parentb8bc136065b6fcdbd123fe11b33b0dab055ff661 (diff)
downloadvyatta-cfg-quagga-5a2647cdb13335b630e692f8b4c1e30ecfc7b8ac.tar.gz
vyatta-cfg-quagga-5a2647cdb13335b630e692f8b4c1e30ecfc7b8ac.zip
Add ability to run modem getty
For some dial in lines, need HAYES modem support.
-rw-r--r--debian/control2
-rw-r--r--scripts/system/vyatta_update_console.pl12
-rw-r--r--templates/system/console/device/type/node.def5
3 files changed, 17 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index b9f35ceb..abc21f28 100644
--- a/debian/control
+++ b/debian/control
@@ -23,7 +23,6 @@ Depends: acpid,
udev (>= 160-1),
rsyslog | system-log-daemon,
vyatta-busybox,
- whois,
sudo,
snmpd (>= 5.4.2.1-vyatta11),
vyatta-keepalived (>= 1.1.15-1-vyatta-5),
@@ -38,6 +37,7 @@ Depends: acpid,
installation-report,
laptop-detect,
usbutils,
+ mgetty,
tasksel,
snmp,
tcpdump,
diff --git a/scripts/system/vyatta_update_console.pl b/scripts/system/vyatta_update_console.pl
index 388d3d2c..3c3b7d2d 100644
--- a/scripts/system/vyatta_update_console.pl
+++ b/scripts/system/vyatta_update_console.pl
@@ -57,8 +57,18 @@ sub update_inittab {
foreach my $tty ($config->listNodes()) {
my $speed = $config->returnValue("$tty speed");
$speed = 9600 unless $speed;
+ my $type = $config->returnValue("$tty type");
- print {$tmp} "T$id:23:respawn:/sbin/getty $speed $tty\n";
+ print {$tmp} "T$id:23:respawn:";
+
+ # Three cases modem, direct, and normal
+ if ($type eq "modem") {
+ print {$tmp} "/sbin/mgetty -x0 -s";
+ } else {
+ print {$tmp} "/sbin/getty";
+ print {$tmp} " -L" if ($type eq "direct");
+ }
+ print {$tmp} "$speed $tty\n";
++$id;
}
close $tmp;
diff --git a/templates/system/console/device/type/node.def b/templates/system/console/device/type/node.def
new file mode 100644
index 00000000..9bce3b38
--- /dev/null
+++ b/templates/system/console/device/type/node.def
@@ -0,0 +1,5 @@
+type: txt
+allowed: echo modem direct
+help: Configure serial line paremeters
+val_help: direct ; Ignore carrier detect (local line)
+val_help: modem ; Use HAYES modem answering sequence