summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-04-02 15:04:37 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-04-02 15:04:37 -0700
commit69f910eb95116a9d9e4aec5844e14df029953163 (patch)
tree61ab00f00c09ddbe46c590f2023a93a3de863ded
parent73712ffe263d0f12cf6db914e9457509bc62f045 (diff)
parent30e1432faf2dfd1ec3ab78479355e08b262521e2 (diff)
downloadvyatta-cfg-quagga-69f910eb95116a9d9e4aec5844e14df029953163.tar.gz
vyatta-cfg-quagga-69f910eb95116a9d9e4aec5844e14df029953163.zip
Merge branch 'jenner' of suva.vyatta.com:/git/vyatta-cfg-quagga into jenner
-rw-r--r--debian/changelog22
-rwxr-xr-xscripts/bgp/vyatta-bgp.pl5
2 files changed, 25 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 40885b3a..eb17ae65 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,25 @@
+vyatta-cfg-quagga (0.18.12) unstable; urgency=low
+
+ * Revert "Remove redundant check-as call since it doesn't work with
+ peer-groups."
+ * Fix check-as to not check on a peer-group.
+
+ -- Stig Thormodsrud <stig@vyatta.com> Tue, 31 Mar 2009 17:44:30 -0700
+
+vyatta-cfg-quagga (0.18.11) unstable; urgency=low
+
+ * Remove redundant check-as call since it doesn't work with peer-
+ groups.
+
+ -- Stig Thormodsrud <stig@vyatta.com> Tue, 31 Mar 2009 16:27:09 -0700
+
+vyatta-cfg-quagga (0.18.10) unstable; urgency=low
+
+ * Swap order of parameters
+ * Fix template for soft-reconfiguration
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Tue, 31 Mar 2009 09:58:12 -0700
+
vyatta-cfg-quagga (0.18.9) unstable; urgency=low
* Fix error checking of remote-as
diff --git a/scripts/bgp/vyatta-bgp.pl b/scripts/bgp/vyatta-bgp.pl
index 2609e381..610fb571 100755
--- a/scripts/bgp/vyatta-bgp.pl
+++ b/scripts/bgp/vyatta-bgp.pl
@@ -82,16 +82,17 @@ sub check_for_peer_groups {
}
}
-# make sure nodes are either in a peer group of have
+# make sure nodes are either in a peer group or have
# a remote AS assigned to them.
sub check_as {
my ($neighbor, $as, $pg) = @_;
die "neighbor not defined\n" unless $neighbor;
- die "neighbor:$neighbor must be address\n" unless is_ip_v4_or_v6($neighbor);
die "AS not defined\n" unless $as;
# if this is peer-group then short circuit this
+ return if ! is_ip_v4_or_v6($neighbor);
+
my $config = new Vyatta::Config;
$config->setLevel("protocols bgp $as neighbor $neighbor");
my $remoteas = $config->returnValue("remote-as");