summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Gilligan <gilligan@vyatta.com>2009-09-04 02:54:35 -0700
committerBob Gilligan <gilligan@vyatta.com>2009-09-04 02:54:35 -0700
commitc2cedb63022d3e0724030d9a4de80a065d041fb6 (patch)
tree5cabb167657566222ca7f2f2179d819932cceacc
parent824ce98534adf36ddc51c22bf8c103cf1b519644 (diff)
parentfd910e721e6d277f9792524c015f3d4b7f8c2473 (diff)
downloadvyatta-cfg-quagga-c2cedb63022d3e0724030d9a4de80a065d041fb6.tar.gz
vyatta-cfg-quagga-c2cedb63022d3e0724030d9a4de80a065d041fb6.zip
Merge branch 'kenwood' of http://git.vyatta.com/vyatta-cfg-system into kenwood
-rw-r--r--debian/changelog13
-rw-r--r--templates/system/login/user/node.tag/authentication/encrypted-password/node.def9
2 files changed, 22 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ffe01fe7..0a5288be 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+vyatta-cfg-system (0.15.72) unstable; urgency=low
+
+ * Revert "Validate encrypted password field"
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Fri, 04 Sep 2009 09:35:58 -0700
+
+vyatta-cfg-system (0.15.71) unstable; urgency=low
+
+ * Don't change name of non-ethernet devices
+ * Validate encrypted password field
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Thu, 03 Sep 2009 11:18:24 -0700
+
vyatta-cfg-system (0.15.70) unstable; urgency=low
* Bonding: load module with MII monitor enabled
diff --git a/templates/system/login/user/node.tag/authentication/encrypted-password/node.def b/templates/system/login/user/node.tag/authentication/encrypted-password/node.def
index 3c12bdc3..49b7fd04 100644
--- a/templates/system/login/user/node.tag/authentication/encrypted-password/node.def
+++ b/templates/system/login/user/node.tag/authentication/encrypted-password/node.def
@@ -1,2 +1,11 @@
type: txt
help: Set encrypted password
+# Allow * or ! to disable account
+# DES format password (13 characters)
+# MD5 format ($1) and SHA format passwords
+syntax:expression: ($VAR(@) == "*" || $VAR(*) == "!" \
+ || ( pattern $VAR(@) "^[a-zA-Z0-9\.\/]{13}$" ) \
+ || ( pattern $VAR(@) "^\\$1\\$[a-zA-Z0-9\./]*\\$[a-zA-Z0-9\./]{22}$" ) \
+ || ( pattern $VAR(@) "^\\$5\\$[a-zA-Z0-9\./]*\\$[a-zA-Z0-9\./]{43}$" ) \
+ || ( pattern $VAR(@) "^\\$6\\$[a-zA-Z0-9\./]*\\$[a-zA-Z0-9\./]{86}$" )) \
+ ; "Not a valid encrypted password for user $VAR(../../@)"