summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2011-12-27 10:34:21 -0800
committerJohn Southworth <john.southworth@vyatta.com>2011-12-27 10:34:21 -0800
commit60afd711d191f9a4a2424f45b1099e9fedb52d73 (patch)
tree831dfcd3427643a62406cd8ce0bc572635d799d8
parent7fda504b6dcdabdffc3245b2f28c320a3a427921 (diff)
parente163a558e30b574703b3d083b98c02fe6124ec99 (diff)
downloadvyatta-cfg-quagga-60afd711d191f9a4a2424f45b1099e9fedb52d73.tar.gz
vyatta-cfg-quagga-60afd711d191f9a4a2424f45b1099e9fedb52d73.zip
Merge branch 'oxnard' of git.vyatta.com:/git/vyatta-cfg-system into oxnard
-rw-r--r--debian/changelog7
-rw-r--r--debian/vyatta-cfg-system.postinst.in2
-rwxr-xr-xscripts/system/vyatta_interface_rescan7
3 files changed, 15 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ad53c25e..646f7720 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+vyatta-cfg-system (0.19.149) unstable; urgency=low
+
+ * interfaces: don't add config for missing devices
+ * install: fix warning message when package is updated
+
+ -- Stephen Hemminger <shemminger@vyatta.com> Wed, 21 Dec 2011 17:53:56 -0800
+
vyatta-cfg-system (0.19.148) unstable; urgency=low
* Extra grat. arps are not needed for vmac interfaces
diff --git a/debian/vyatta-cfg-system.postinst.in b/debian/vyatta-cfg-system.postinst.in
index cc412632..2595aec1 100644
--- a/debian/vyatta-cfg-system.postinst.in
+++ b/debian/vyatta-cfg-system.postinst.in
@@ -217,7 +217,7 @@ do
done
# add vyatta-config-reboot-params to start at boot up
-update-rc.d vyatta-config-reboot-params defaults
+update-rc.d vyatta-config-reboot-params start 20 S
# Local Variables:
# mode: shell-script
diff --git a/scripts/system/vyatta_interface_rescan b/scripts/system/vyatta_interface_rescan
index 5b72a480..eb45da60 100755
--- a/scripts/system/vyatta_interface_rescan
+++ b/scripts/system/vyatta_interface_rescan
@@ -115,6 +115,13 @@ sub interface_rescan {
foreach my $ifname (sort @interfaces) {
my $hwaddr = get_hwid("$VYATTAUDEV/$ifname");
+
+ # Ignore devices that disappear (or get renamed)
+ unless (-d "/sys/class/net/$ifname") {
+ syslog(LOG_INFO, "%s: does not exist", $ifname);
+ next;
+ }
+
unless (persistent_address($hwaddr)) {
syslog(LOG_NOTICE, "%s: skipping address %s is not persistent",
$ifname, $hwaddr);