summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Grennan <tgrennan@io.vyatta.com>2007-12-19 13:08:59 -0800
committerTom Grennan <tgrennan@io.vyatta.com>2007-12-19 13:08:59 -0800
commit793d580050edada4b4468b0d8044615ff5fc15aa (patch)
tree3b5ff34d527edffc2e3bd772c591efc51b3bebaf
parent77f192de9e7652c4fe43b3a2f92bcc5ee0314b9a (diff)
downloadvyatta-cfg-quagga-793d580050edada4b4468b0d8044615ff5fc15aa.tar.gz
vyatta-cfg-quagga-793d580050edada4b4468b0d8044615ff5fc15aa.zip
Revert "add init script to force udev settle before itf configured"
This is unnecessary if the config.boot file is available before udevd starts. This reverts commit a9cd192305b779cb62aecd858ad9a4e5a1fbcad4.
-rw-r--r--Makefile.am11
-rw-r--r--debian/vyatta-cfg-system.postinst.in2
-rwxr-xr-xetc/init.d/vyatta-udev58
3 files changed, 4 insertions, 67 deletions
diff --git a/Makefile.am b/Makefile.am
index a05602cb..39d65e30 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,7 @@
-cfgdir = $(datadir)/vyatta-cfg/templates
-share_perl5dir = $(datarootdir)/perl5
-libudevdir = /lib/udev
-etcudevdir = /etc/udev
-initddir = /etc/init.d
+cfgdir = $(datadir)/vyatta-cfg/templates
+share_perl5dir = $(datarootdir)/perl5
+libudevdir = /lib/udev
+etcudevdir = /etc/udev
bin_SCRIPTS =
sbin_SCRIPTS =
@@ -41,8 +40,6 @@ sysconf_DATA += sysconf/config.boot.default
libudev_SCRIPTS = scripts/vyatta_net_name
etcudev_DATA = sysconf/vyatta-net.rules
-initd_SCRIPTS = etc/init.d/vyatta-udev
-
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
diff --git a/debian/vyatta-cfg-system.postinst.in b/debian/vyatta-cfg-system.postinst.in
index b747b786..13ba6dc6 100644
--- a/debian/vyatta-cfg-system.postinst.in
+++ b/debian/vyatta-cfg-system.postinst.in
@@ -22,8 +22,6 @@ esac
ln -sf ../vyatta-net.rules /etc/udev/rules.d/$vyatta_net_rules
-update-rc.d vyatta-udev start 21 S .
-
if [ "$sysconfdir" != "/etc" ]; then
# for "admin" level (FIXME)
sed -i 's/^# %sudo ALL=NOPASSWD: ALL/%sudo ALL=NOPASSWD: ALL/' /etc/sudoers
diff --git a/etc/init.d/vyatta-udev b/etc/init.d/vyatta-udev
deleted file mode 100755
index 5c2c1d37..00000000
--- a/etc/init.d/vyatta-udev
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/bin/bash
-### BEGIN INIT INFO
-# Provides: vyatta-udev
-# Required-Start: udev module-init-tools
-# Required-Stop:
-# Default-Start: S
-# Default-Stop:
-# Short-Description: Trigger udev net subsystem to process interface renaming
-### END INIT INFO
-# **** License ****
-# Version: VPL 1.0
-#
-# The contents of this file are subject to the Vyatta Public License
-# Version 1.0 ("License"); you may not use this file except in
-# compliance with the License. You may obtain a copy of the License at
-# http://www.vyatta.com/vpl
-#
-# Software distributed under the License is distributed on an "AS IS"
-# basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See
-# the License for the specific language governing rights and limitations
-# under the License.
-#
-# This code was originally developed by Vyatta, Inc.
-# Portions created by Vyatta are Copyright (C) 2007 Vyatta, Inc.
-# All Rights Reserved.
-#
-# Author: Tom Grennan <tgrennan@vyatta.com>
-# **** End License ****
-
-. /lib/lsb/init-functions
-
-: ${vyatta_env:=/etc/default/vyatta}
-source $vyatta_env
-
-declare progname=${0##*/}
-declare action=$1; shift
-
-start ()
-{
- log_action_begin_msg "Trigger rename of network interfaces"
- udevtrigger --subsystem-match=net
- udevsettle
- log_action_end_msg $?
-}
-
-case "$action" in
- start) start ;;
- stop|restart|force-reload) true ;;
- *) log_failure_msg "usage: $progname [ start|stop|restart ]" ;
- false ;;
-esac
-
-exit $?
-
-# Local Variables:
-# mode: shell-script
-# sh-indentation: 4
-# End: