summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStig Thormodsrud <stig@vyatta.com>2009-11-02 18:31:18 -0800
committerStig Thormodsrud <stig@vyatta.com>2009-11-02 18:31:18 -0800
commit1b9a722a77305bfc607a5a34317fbc743d2ae4bb (patch)
tree1a2dbccb40c30e6f151aeb6e139f62ad54e8c81a
parenta6ead18568860f4a574325198ecfe188c69eda28 (diff)
parent4b6feb5e30012862b6a91578914ef2194d242f31 (diff)
downloadvyatta-cfg-quagga-1b9a722a77305bfc607a5a34317fbc743d2ae4bb.tar.gz
vyatta-cfg-quagga-1b9a722a77305bfc607a5a34317fbc743d2ae4bb.zip
Merge branch 'kenwood' of http://git.vyatta.com/vyatta-cfg-system into kenwood
-rw-r--r--Makefile.am2
-rw-r--r--debian/changelog12
-rw-r--r--debian/vyatta-cfg-system.postinst.in2
-rw-r--r--lib/Vyatta/Login/RadiusServer.pm4
-rwxr-xr-xscripts/install/install-functions14
-rwxr-xr-xscripts/install/install-image24
-rwxr-xr-xscripts/rl-system.init6
-rw-r--r--sysconf/pam_radius.cfg (renamed from sysconf/pam-radius)4
8 files changed, 54 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 29619127..99142777 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,7 +70,7 @@ sysconf_DATA += sysconf/securetty
sysconf_DATA += sysconf/vyatta-sysctl.conf
sysconf_DATA += sysconf/blacklist.DSA-1024
sysconf_DATA += sysconf/blacklist.RSA-2048
-sysconf_DATA += sysconf/pam-radius
+sysconf_DATA += sysconf/pam_radius.cfg
libudev_SCRIPTS = scripts/vyatta_net_name
etcudev_DATA = sysconf/vyatta-net.rules
diff --git a/debian/changelog b/debian/changelog
index c4c1a0aa..4d6c8583 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+vyatta-cfg-system (0.15.96) unstable; urgency=low
+
+ [ An-Cheng Huang ]
+ * use top-level pid for progress indicator
+
+ [ Stephen Hemminger ]
+ * Don't want/need --package option to pam-auth-update
+ * Reset PAM configuration on boot
+ * rename pam-radius to pam_radius.cfg
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Mon, 02 Nov 2009 17:28:17 -0800
+
vyatta-cfg-system (0.15.95) unstable; urgency=low
[ David S. Madole ]
diff --git a/debian/vyatta-cfg-system.postinst.in b/debian/vyatta-cfg-system.postinst.in
index 95fcd1ca..3a914f7f 100644
--- a/debian/vyatta-cfg-system.postinst.in
+++ b/debian/vyatta-cfg-system.postinst.in
@@ -149,7 +149,7 @@ update-rc.d -f ssh remove >/dev/null
sed -i 's/requisite[ \t][ \t]*pam_securetty.so/required pam_securetty.so/' $rootfsdir/etc/pam.d/login
# Install pamradius config (should come with radius client eventually)
-cp $sysconfdir/pam-radius /usr/share/pam-configs/radius
+cp $sysconfdir/pam_radius.cfg /usr/share/pam-configs/radius
[ grep "blacklist.*snd-pcsp" >&/dev/null ] || echo "blacklist snd-pcsp" >>/etc/modprobe.d/blacklist
diff --git a/lib/Vyatta/Login/RadiusServer.pm b/lib/Vyatta/Login/RadiusServer.pm
index 43f78f90..f8b67830 100644
--- a/lib/Vyatta/Login/RadiusServer.pm
+++ b/lib/Vyatta/Login/RadiusServer.pm
@@ -29,12 +29,12 @@ my $PAM_RAD_END = '# END Vyatta Radius servers';
sub remove_pam_radius {
return system("sudo DEBIAN_FRONTEND=noninteractive"
- . " pam-auth-update --package --remove radius") == 0;
+ . " pam-auth-update --remove radius") == 0;
}
sub add_pam_radius {
return system("sudo DEBIAN_FRONTEND=noninteractive"
- . " pam-auth-update --package --add radius") == 0;
+ . " pam-auth-update radius") == 0;
}
sub update {
diff --git a/scripts/install/install-functions b/scripts/install/install-functions
index 3bdc1fde..29707dff 100755
--- a/scripts/install/install-functions
+++ b/scripts/install/install-functions
@@ -43,18 +43,20 @@ VYATTA_CFG_DIR=${vyatta_sysconfdir}/config
# the floppy config dir
FD_CFG_DIR=/media/floppy/config
-# Process ID for progress_indicator
-SPID=$$
-
+# PROGRESS_PID can be exported by top-level script
progress_indicator () {
+ local spid=$PROGRESS_PID
+ if [ -z "$spid" ]; then
+ spid=$$
+ fi
case "$1" in
start)
- $vyatta_bindir/progress-indicator $SPID &
+ $vyatta_bindir/progress-indicator $spid &
;;
*)
- if ! rm /tmp/pi.$SPID 2>/dev/null; then
+ if ! rm /tmp/pi.$spid 2>/dev/null; then
sleep 1
- rm /tmp/pi.$SPID 2>/dev/null
+ rm /tmp/pi.$spid 2>/dev/null
fi
sleep 1
echo -n -e "\b"
diff --git a/scripts/install/install-image b/scripts/install/install-image
index 0bf31a00..6ed0f732 100755
--- a/scripts/install/install-image
+++ b/scripts/install/install-image
@@ -5,6 +5,8 @@ source /opt/vyatta/sbin/install-functions
# export INSTALL_LOG for the scripts invoked
export INSTALL_LOG=/tmp/install-$$.log
+# export PROGRESS_PID for the scripts invoked
+export PROGRESS_PID=$$
# file for get-partition output
PART_FILE=''
@@ -114,12 +116,30 @@ fi
trap sig_handler INT KILL
trap exit_handler EXIT
+cat <<EOF
+Welcome to the Vyatta install program. This script
+will walk you through the process of installing the
+Vyatta image to a local hard drive.
+EOF
+
+response=''
+while [ -z $response ]
+do
+ echo -n "Would you like to continue? (Yes/No) [Yes]: "
+ response=$(get_response "Yes" "Yes No Y N")
+ if [ "$response" == "no" ] || [ "$response" == "n" ]; then
+ fail_exit 'Ok then.'
+ fi
+done
+
if is_live_cd_boot; then
if [ -n "$NEW_ISO" ]; then
- fail_exit 'Do not specify an image when installing from a live CD.'
+ echo 'You are trying to install from a live CD boot. The live CD image'
+ fail_exit 'will be used. Do not specify an ISO image file.'
fi
elif [ -z "$NEW_ISO" ]; then
- fail_exit 'Must specify an image to install.'
+ echo 'You are trying to install from an already installed system. An ISO'
+ fail_exit 'image file to install must be specified.'
else
# installing on an installed system. set up the new image.
set_up_new_iso
diff --git a/scripts/rl-system.init b/scripts/rl-system.init
index 3ca02ed2..2cca5d98 100755
--- a/scripts/rl-system.init
+++ b/scripts/rl-system.init
@@ -169,6 +169,11 @@ setup_ntp_config_file () {
log_failure_msg "NTP template config file doesn\'t exist"
fi
}
+
+# restore PAM back to virgin state (no radius other services)
+pam_reset () {
+ DEBIAN_FRONTEND=noninteractive pam-auth-update unix
+}
start () {
udev_rescan
@@ -182,6 +187,7 @@ start () {
sysctl -q -e -p /opt/vyatta/etc/vyatta-sysctl.conf ||
log_failure_msg "can\'t configure kernel settings"
set_ipv6_params
+ pam_reset
update_version_info
## Clear out apt config file--it will be filled in by rtrmgr
diff --git a/sysconf/pam-radius b/sysconf/pam_radius.cfg
index 0409dd44..3b9d92fc 100644
--- a/sysconf/pam-radius
+++ b/sysconf/pam_radius.cfg
@@ -1,5 +1,5 @@
-Name: Radius authentication
-Default: no
+Name: Radius client
+Default: yes
Priority: 512
Auth-Type: Primary
Auth: