summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Grennan <tgrennan@io.vyatta.com>2007-12-13 18:35:20 -0800
committerTom Grennan <tgrennan@io.vyatta.com>2007-12-13 18:35:20 -0800
commite6ed55f7593a0f4bc2700bc7b90903bb012e27f6 (patch)
treeb0f2c082f34c8a134631e0cae21314e164720243 /Makefile.am
parent5ba8cf8393030d75c03a15551a57831f3f0908a4 (diff)
downloadvyatta-cfg-quagga-e6ed55f7593a0f4bc2700bc7b90903bb012e27f6.tar.gz
vyatta-cfg-quagga-e6ed55f7593a0f4bc2700bc7b90903bb012e27f6.zip
process device persistence through udev rules rather than init script
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c3aea76e..b3db5d18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,7 @@
cfgdir = $(datadir)/vyatta-cfg/templates
-share_perl5dir = /opt/vyatta/share/perl5
+share_perl5dir = $(datarootdir)/perl5
+libudevdir = /lib/udev
+etcudevdir = /etc/udev
bin_SCRIPTS =
sbin_SCRIPTS =
@@ -30,6 +32,9 @@ sysconf_DATA += sysconf/syslog.conf
sysconf_DATA += sysconf/default_ssh
sysconf_DATA += sysconf/config.boot.default
+libudev_SCRIPTS = scripts/vyatta_net_name
+etcudev_DATA = sysconf/vyatta-net.rules
+
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd