summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2007-10-01 13:14:31 -0700
committerAn-Cheng Huang <ancheng@vyatta.com>2007-10-01 13:14:31 -0700
commitcfa368bbc1d4c55c42c60838e04fc523625932b7 (patch)
treee439217d7e3ebb726b9954d7f823db2b47f18c9d /Makefile.am
downloadvyatta-cfg-quagga-cfa368bbc1d4c55c42c60838e04fc523625932b7.tar.gz
vyatta-cfg-quagga-cfa368bbc1d4c55c42c60838e04fc523625932b7.zip
initial import (from eureka /cli).upstream
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..955226bc
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,11 @@
+cfgdir = $(datadir)/vyatta-cfg/templates
+
+sbin_SCRIPTS = scripts/bgp/vyatta-bgp.pl
+sbin_SCRIPTS += scripts/policy/vyatta-policy.pl
+
+cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
+ cpio -0pd
+
+install-exec-hook:
+ mkdir -p $(DESTDIR)$(cfgdir)
+ cd templates; $(cpiop) $(DESTDIR)$(cfgdir)