summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@sydney.vyatta.com>2007-10-18 17:53:03 -0700
committerAn-Cheng Huang <ancheng@sydney.vyatta.com>2007-10-18 17:53:03 -0700
commit758f31ccdf9e6da2d7dd1752ddb6fdefa13590e6 (patch)
treee39be26cb93fa4f3441bd9a67264251d6e4bb7ba /debian
parent9c04f3d77a812f648842c72e70f17acfdd08c6b6 (diff)
downloadvyatta-cfg-quagga-758f31ccdf9e6da2d7dd1752ddb6fdefa13590e6.tar.gz
vyatta-cfg-quagga-758f31ccdf9e6da2d7dd1752ddb6fdefa13590e6.zip
* import system config files from fairfield/xorp/sysconf.
* add dependencies and postinst actions.
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/vyatta-cfg-system.postinst.in36
2 files changed, 36 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index d0095055..2d092ba5 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,7 @@ Depends: bash (>= 3.1),
perl (>= 5.8.8),
procps (>= 1:3.2.7-3),
coreutils (>= 5.97-5.3),
- vyatta-cfg, sysv-rc, ifrename, ntp, sysklogd
+ vyatta-cfg, sysv-rc, ifrename, ntp, sysklogd, busybox, ssh
Suggests: util-linux (>= 2.13-5),
net-tools,
ethtool,
diff --git a/debian/vyatta-cfg-system.postinst.in b/debian/vyatta-cfg-system.postinst.in
index 39c4e4d1..3d02ded9 100644
--- a/debian/vyatta-cfg-system.postinst.in
+++ b/debian/vyatta-cfg-system.postinst.in
@@ -1,8 +1,42 @@
#!/bin/bash
prefix=@prefix@
+exec_prefix=@exec_prefix@
sysconfdir=@sysconfdir@
+bindir=@bindir@
+sbindir=@sbindir@
-# remove init of daemons that we manage
+# remove init of daemons that we start/stop
update-rc.d -f ntp remove >/dev/null
+# create symlinks
+for bb in telnetd telnet tftp ftpget ftpput; do
+ ln -sf /bin/busybox ${sbindir}/${bb}
+done
+ln -sf ${bindir}/progress-indicator /usr/bin/progress-indicator
+
+# remove the config files
+for conf in hosts motd.tail ntp.conf syslog.conf logrotate.d/messages; do
+ [ -f /etc/$conf ] && \
+ ( mv /etc/$conf /etc/$conf.vyatta-save && touch /etc/$conf );
+done
+
+# use our config files
+if [ "$sysconfdir" != "/etc" ]; then
+ for conf in hosts motd.tail syslog.conf; do
+ cp $sysconfdir/$conf /etc/$conf
+ done
+ cp $sysconfdir/logrotate_messages /etc/logrotate.d/messages
+fi
+
+# update crontab for logrotate
+grep -v logrotate /etc/crontab>/etc/crontab.$$
+echo "*/10 * * * * /usr/sbin/logrotate /etc/logrotate.conf" >> /etc/crontab.$$
+rm /etc/crontab
+mv /etc/crontab.$$ /etc/crontab
+crontab /etc/crontab
+
+# create needed directories
+mkdir -p /etc/raddb
+mkdir -p /var/log/{user,vrrpd}
+