summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorRobert Bays <robert@vyatta.com>2010-08-30 15:47:01 -0700
committerRobert Bays <robert@vyatta.com>2010-08-30 15:47:01 -0700
commit0cba88a9b7a7439741f1b371a9c290e41380c91b (patch)
tree15373235080940ebb4ef34cd2df29e6b42a8a2d7 /scripts
parent3fb0bdfb2a7c61f0b5d500d15381cbcdaeceb548 (diff)
parenta785fe685d9fa0edd813e2a53f1ebbc227ba2c7f (diff)
downloadvyatta-cfg-quagga-0cba88a9b7a7439741f1b371a9c290e41380c91b.tar.gz
vyatta-cfg-quagga-0cba88a9b7a7439741f1b371a9c290e41380c91b.zip
Merge commit 'a785fe685d9fa0edd813e2a53f1ebbc227ba2c7f' into mendocino
Conflicts: debian/changelog scripts/bgp/vyatta-bgp.pl
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/bgp/vyatta-bgp.pl3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/bgp/vyatta-bgp.pl b/scripts/bgp/vyatta-bgp.pl
index a26501e0..291113eb 100755
--- a/scripts/bgp/vyatta-bgp.pl
+++ b/scripts/bgp/vyatta-bgp.pl
@@ -1243,7 +1243,8 @@ sub bgp_type_change {
# check if changing from iBGP to eBGP
if ( (iBGP_peer(1, $neighbor, $as, $ntype)) && (! iBGP_peer(0, $neighbor, $as, $ntype)) ) {
- if ($config->exists("$as $ntype $neighbor route-reflector-client")) {
+ if ( $config->exists("$as $ntype $neighbor route-reflector-client") ||
+ $config->exists("$as $ntype $neighbor address-family ipv6-unicast route-reflector-client") ) {
return "can not set route-reflector-client and an eBGP remote-as at the same time\n";
}
}