summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog88
-rw-r--r--sysconf/LICENSE10
-rw-r--r--templates/service/dns/dynamic/interface/node.def25
3 files changed, 105 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 0da5d36e..d1f1f323 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,91 @@
+vyatta-cfg-system (0.15.1) unstable; urgency=low
+
+ [ Rick Balocca ]
+ * Fix for bug http://bugzilla.vyatta.com/show_bug.cgi?id=3731
+
+ [ Stephen Hemminger ]
+ * Fix password changer to deal with update config format
+ * Make standalone passwd reset change vyatta not root
+ * Leave root account disabled
+ * Standalone tool now changes vyatta not root password
+
+ [ Rick Balocca ]
+ * Fix typo
+
+ [ rbalocca ]
+ * Fix for bug http://bugzilla.vyatta.com/show_bug.cgi?id=2426
+
+ [ Stephen Hemminger ]
+ * Mount root filesystem with noatime
+ * Add completion for allowed values
+ * Don't force rebuild of ssh_host_key on each boot
+ * Remove OFR from grub lines
+ * fix grammar of previous patch
+ * Don't restart sshd if not needed
+ * Always restart ssh
+
+ [ Robert Bays ]
+ * add basic tacacs+ support
+
+ [ Stephen Hemminger ]
+ * Avoid sleep in ntp restart
+ * Speed up boot
+ * Remove extra call to set hwclock on startup
+ * typo in last commit
+ * Speed up addition of users to system
+
+ [ Mohit Mehta ]
+ * dhcp action scripts for linkup/down
+
+ [ Stephen Hemminger ]
+ * Fix sysctl key values
+
+ [ An-Cheng Huang ]
+ * add support for development build
+
+ [ Mohit Mehta ]
+ * Fix Bug 3917 dhcp brings interface up for lease acquire/renew even
+ though interface has been disabled in CLI
+
+ [ Stephen Hemminger ]
+ * Rename VyattaKeepalived to Vyatta::Keepalived
+ * Convert to Vyatta::Config hierarchy
+
+ [ Bob Gilligan ]
+ * Bugfix 3747: Allow user to break previously existing RAID group.
+
+ [ Stephen Hemminger ]
+ * VyattaConfig -> Vyatta::Config
+ * Add correct help for bonding modes
+
+ [ Rick Balocca ]
+ * Fix for bug http://bugzilla.vyatta.com/show_bug.cgi?id=3963
+
+ [ Stephen Hemminger ]
+ * use vyatta-link-detect
+ * Remove OFR from grub lines
+ * fix grammar of previous patch
+ * need full path to linkdetect
+
+ [ An-Cheng Huang ]
+ * update maintainer information
+ * "files" file should be removed before package build
+
+ [ Stephen Hemminger ]
+ * Add acpid
+
+ [ slioch ]
+ * removed unprintable form-feed characters. This was causing xml
+ validation to fail within the webgui.
+
+ [ Mohit Mehta ]
+ * Fix Bug 4022 dynamic dns config fails during system boot if
+ interface does not exist
+
+ [ An-Cheng Huang ]
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Thu, 08 Jan 2009 09:25:28 -0800
+
vyatta-cfg-system (0.15) unstable; urgency=low
3.2.0
diff --git a/sysconf/LICENSE b/sysconf/LICENSE
index 3912109b..6d45519c 100644
--- a/sysconf/LICENSE
+++ b/sysconf/LICENSE
@@ -55,7 +55,7 @@ patent must be licensed for everyone's free use or not licensed at all.
The precise terms and conditions for copying, distribution and
modification follow.
-
+
GNU GENERAL PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
@@ -110,7 +110,7 @@ above, provided that you also meet all of these conditions:
License. (Exception: if the Program itself is interactive but
does not normally print such an announcement, your work based on
the Program is not required to print an announcement.)
-
+
These requirements apply to the modified work as a whole. If
identifiable sections of that work are not derived from the Program,
and can be reasonably considered independent and separate works in
@@ -168,7 +168,7 @@ access to copy from a designated place, then offering equivalent
access to copy the source code from the same place counts as
distribution of the source code, even though third parties are not
compelled to copy the source along with the object code.
-
+
4. You may not copy, modify, sublicense, or distribute the Program
except as expressly provided under this License. Any attempt
otherwise to copy, modify, sublicense or distribute the Program is
@@ -225,7 +225,7 @@ impose that choice.
This section is intended to make thoroughly clear what is believed to
be a consequence of the rest of this License.
-
+
8. If the distribution and/or use of the Program is restricted in
certain countries either by patents or by copyrighted interfaces, the
original copyright holder who places the Program under this License
@@ -278,7 +278,7 @@ PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES.
END OF TERMS AND CONDITIONS
-
+
How to Apply These Terms to Your New Programs
If you develop a new program, and you want it to be of the greatest
diff --git a/templates/service/dns/dynamic/interface/node.def b/templates/service/dns/dynamic/interface/node.def
index bbf0c310..cf7483bb 100644
--- a/templates/service/dns/dynamic/interface/node.def
+++ b/templates/service/dns/dynamic/interface/node.def
@@ -1,19 +1,6 @@
tag:
help: Set interface to send DDNS updates for
type: txt
-syntax:expression: exec "
- intf_array=($(awk '$1 ~ /:/ { print $1 }' /proc/net/dev))
- intf_array_len=${#intf_array[*]}
- i=0
- while [ $i -lt $intf_array_len ]; do
- temp=${intf_array[$i]%:*}
- if [ \"$temp\" == \"$VAR(@)\" ] ; then
- exit 0
- fi
- let i++
- done
- echo Invalid interface [$VAR(@)]
- exit 1 "
allowed: local -a array ;
array=($(awk '$1 ~ /:/ { print $1 }' /proc/net/dev));
@@ -28,4 +15,16 @@ end:expression: "if [ -f \"/tmp/ddclient_$VAR(@).$PPID\" ]; then \
rm /tmp/ddclient_$VAR(@).$PPID; \
else \
sudo /opt/vyatta/sbin/vyatta-dynamic-dns.pl --update-dynamicdns --interface $VAR(@); \
+ # generate a warning if interface does not exist on system
+ intf_array=($(awk '$1 ~ /:/ { print $1 }' /proc/net/dev))
+ intf_array_len=${#intf_array[*]}
+ i=0
+ while [ $i -lt $intf_array_len ]; do
+ temp=${intf_array[$i]%:*}
+ if [ \"$temp\" == \"$VAR(@)\" ] ; then
+ exit 0
+ fi
+ let i++
+ done
+ echo Dynamic DNS warning : interface [$VAR(@)] does not exist on system
fi; "