summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog25
-rw-r--r--debian/control2
-rwxr-xr-xscripts/vyatta-grub-setup1
-rw-r--r--templates/interfaces/ethernet/node.tag/bridge-group/bridge/node.def2
-rw-r--r--templates/interfaces/tunnel/node.tag/local-ip/node.def6
5 files changed, 31 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 219b68d0..59ab6bde 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,28 @@
+vyatta-cfg-system (0.15.6) unstable; urgency=low
+
+ * Change "syntax" check to a "commit" check.
+
+ -- Stig Thormodsrud <stig@vyatta.com> Tue, 24 Mar 2009 17:53:17 -0700
+
+vyatta-cfg-system (0.15.5) unstable; urgency=low
+
+ * Save interface description in kernel
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Mon, 23 Mar 2009 12:27:42 -0700
+
+vyatta-cfg-system (0.15.4) unstable; urgency=low
+
+ [ Stephen Hemminger ]
+ * Change update to create on multi-nodes
+
+ [ Mohit Mehta ]
+ * will help debug bug 4181 if and when it happens
+
+ [ An-Cheng Huang ]
+ * use renamed tacplus package
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Mon, 23 Mar 2009 11:11:38 -0700
+
vyatta-cfg-system (0.15.3-14) unstable; urgency=low
* Fix 4190: vrrp may fail to start daemon if previous commit of vrrp
diff --git a/debian/control b/debian/control
index 7bbb5f26..077402e1 100644
--- a/debian/control
+++ b/debian/control
@@ -40,7 +40,7 @@ Depends: sed (>= 4.1.5),
mdadm,
ddclient,
libio-socket-ssl-perl,
- pam-tacplus
+ tacplus
Pre-Depends: bash-completion
Suggests: util-linux (>= 2.13-5),
acpid,
diff --git a/scripts/vyatta-grub-setup b/scripts/vyatta-grub-setup
index 26a322f2..3eed4df4 100755
--- a/scripts/vyatta-grub-setup
+++ b/scripts/vyatta-grub-setup
@@ -138,6 +138,7 @@ fi
# create the grub.cfg file for grub
# The "default=" line selects which boot option will be used by default.
# Numbering starts at 0 for the first option.
+ echo -e "# Generated by $0 at `date`"
echo -e "set default=$default_console"
echo "set timeout=5"
# set serial console options
diff --git a/templates/interfaces/ethernet/node.tag/bridge-group/bridge/node.def b/templates/interfaces/ethernet/node.tag/bridge-group/bridge/node.def
index 1a6cf437..3e562f7f 100644
--- a/templates/interfaces/ethernet/node.tag/bridge-group/bridge/node.def
+++ b/templates/interfaces/ethernet/node.tag/bridge-group/bridge/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set this interface to a bridge-group
-syntax:expression: exec \
+commit:expression: exec \
"/opt/vyatta/sbin/vyatta-interfaces.pl --dev=$VAR(@) --check=bridge"
allowed: /opt/vyatta/sbin/vyatta-interfaces.pl --show=bridge
delete: echo $VAR(@) > /tmp/bridge-no.$PPID
diff --git a/templates/interfaces/tunnel/node.tag/local-ip/node.def b/templates/interfaces/tunnel/node.tag/local-ip/node.def
index 9f9d52c0..0780210d 100644
--- a/templates/interfaces/tunnel/node.tag/local-ip/node.def
+++ b/templates/interfaces/tunnel/node.tag/local-ip/node.def
@@ -1,8 +1,8 @@
type: ipv4
help: Set the local IP address for this tunnel
-syntax:expression: exec "if [ -z \"`ip addr list | grep $VAR(@) `\" ]; then \
- echo IP address $VAR(@) doesn\\'t exist on this system ; \
- exit 1 ; \
+commit:expression: exec "if [ -z \"`ip addr list | grep $VAR(@) `\" ]; then \
+ echo IP address $VAR(@) doesn\\'t exist on this system ; \
+ exit 1 ; \
fi ; "
create:expression: "true"
update:expression: "false" ; \