summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog19
-rwxr-xr-xscripts/install/install-get-partition2
-rwxr-xr-xscripts/vyatta-interfaces.pl2
3 files changed, 22 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e76c1720..b23be36a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,22 @@
+vyatta-cfg-system (0.17.29) unstable; urgency=low
+
+ * Fail gracefully if path is unknown
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Mon, 05 Apr 2010 16:17:35 -0700
+
+vyatta-cfg-system (0.17.28) unstable; urgency=low
+
+ * Improve wording of config info save dialog.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Tue, 30 Mar 2010 12:02:35 -0700
+
+vyatta-cfg-system (0.17.27) unstable; urgency=low
+
+ * Ignore setting CPU affinity on UP systems
+ * Fix test for UP
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Mon, 29 Mar 2010 16:34:57 -0700
+
vyatta-cfg-system (0.17.26) unstable; urgency=low
* run snmpd as user snmp
diff --git a/scripts/install/install-get-partition b/scripts/install/install-get-partition
index f010291e..85c10358 100755
--- a/scripts/install/install-get-partition
+++ b/scripts/install/install-get-partition
@@ -582,7 +582,7 @@ save_old_info() {
if [ $num_images -gt 1 ]; then
image_index=-1
while [ $image_index -lt 0 -o $image_index -ge $num_images ]; do
- echo -n "Which image would you like to use? (1 .. $num_images): "
+ echo -n "From which image would you like to save config information? (1 .. $num_images): "
read num
image_index=$((num - 1))
done
diff --git a/scripts/vyatta-interfaces.pl b/scripts/vyatta-interfaces.pl
index 8970790f..90d8dfc7 100755
--- a/scripts/vyatta-interfaces.pl
+++ b/scripts/vyatta-interfaces.pl
@@ -537,6 +537,8 @@ sub show_config_path {
die "$name does not match any known interface name type\n"
unless $intf;
my $level = $intf->path();
+ die "$name does not have a known path\n" unless $level;
+
$level =~ s/ /\//g;
print "/opt/vyatta/config/active/$level\n";
}