summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xscripts/install/install-image8
2 files changed, 12 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 32d60d50..2fb0cfc6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg-system (0.19.137) unstable; urgency=low
+
+ * Add HTTP headers to identify client and version.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Mon, 05 Dec 2011 17:45:10 -0800
+
vyatta-cfg-system (0.19.136) unstable; urgency=low
* Set accept_local on vrrp interfaces so that transition from 'current
diff --git a/scripts/install/install-image b/scripts/install/install-image
index 5abef7ca..ea8cfd7f 100755
--- a/scripts/install/install-image
+++ b/scripts/install/install-image
@@ -62,8 +62,12 @@ fetch_iso_by_url ()
auth=""
fi
+ client_hdr="-H vyatta-client: install-image"
+ vyatta_version=`dpkg-query --showformat='${Version}' --show vyatta-version`
+ vers_hdr="-H vyatta-version: $vyatta_version"
+
filename="${TEMP_DIR}/${NEW_ISO##*/}"
- curl $auth -f -o $filename $NEW_ISO
+ curl "$client_hdr" "$vers_hdr" $auth -f -o $filename $NEW_ISO
if [ $? -ne 0 ]; then
echo "Unable to fetch ISO from $NEW_ISO"
rm -f $filename
@@ -78,7 +82,7 @@ fetch_iso_by_url ()
echo "ISO download suceeded."
echo "Checking for digital signature file..."
- curl -f -o ${filename}.asc ${NEW_ISO}.asc
+ curl "$client_hdr" "$vers_hdr" -f -o ${filename}.asc ${NEW_ISO}.asc
if [ $? -ne 0 ]; then
echo "Unable to fetch digital signature file."
echo -n "Do you want to continue without signature check? (yes/no) [yes] "