summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xscripts/keepalived/vyatta-vrrp-state.pl2
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6ffd7647..109681ad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg-system (0.19.142) unstable; urgency=low
+
+ * Fix sysctl application for vlan interfaes
+
+ -- John Southworth <john.southworth@vyatta.com> Thu, 08 Dec 2011 11:22:36 -0800
+
vyatta-cfg-system (0.19.141) unstable; urgency=low
* Bugfix 7497: Include auth credentials when fetching the signature
diff --git a/scripts/keepalived/vyatta-vrrp-state.pl b/scripts/keepalived/vyatta-vrrp-state.pl
index 53c7c6c9..bb04df1d 100755
--- a/scripts/keepalived/vyatta-vrrp-state.pl
+++ b/scripts/keepalived/vyatta-vrrp-state.pl
@@ -70,6 +70,7 @@ if ($vrrp_state eq 'backup') {
# comment out for now, too expensive with lots of vrrp's at boot
# Vyatta::Keepalived::snoop_for_master($vrrp_intf, $vrrp_group,
# $vrrp_vips[0], 60);
+ $vrrp_intf =~ s/\./\//g;
system("sysctl -w net.ipv4.conf.".$vrrp_intf."v".$vrrp_group.".arp_filter=1");
system("sysctl -w net.ipv4.conf.".$vrrp_intf."v".$vrrp_group.".accept_local=1");
} elsif ($vrrp_state eq 'master') {
@@ -79,6 +80,7 @@ if ($vrrp_state eq 'backup') {
# requests. Some of those host do respond to gratuitous arp replies
# so here we will send 5 gratuitous arp replies also.
#
+ $vrrp_intf =~ s/\./\//g;
system("sysctl -w net.ipv4.conf.".$vrrp_intf."v".$vrrp_group.".arp_filter=0");
system("sysctl -w net.ipv4.conf.".$vrrp_intf."v".$vrrp_group.".accept_local=1");
foreach my $vip (@vrrp_vips) {