summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--src/local_ip.c4
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bf8522f8..1c457b9d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+vyatta-cfg-system (0.19.154) unstable; urgency=low
+
+ [ Jon Andersson ]
+ * Update to local_ip
+
+ [ Stephen Hemminger ]
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Mon, 09 Jan 2012 14:24:50 -0800
+
vyatta-cfg-system (0.19.153) unstable; urgency=low
* Bugfix 7689: change vrrp auth_type detection 'simple' to 'plaintext-
diff --git a/src/local_ip.c b/src/local_ip.c
index 3707559f..f238acfe 100644
--- a/src/local_ip.c
+++ b/src/local_ip.c
@@ -46,7 +46,9 @@ int main(int argc, char **argv)
return -1;
}
} else {
- struct sockaddr_in6 sin6;
+ struct sockaddr_in6 sin6 = {
+ .sin6_family = AF_INET6,
+ };
if (inet_pton(af, argv[1], &sin6.sin6_addr) <= 0) {
fprintf(stderr, "%s: invalid address\n", argv[1]);