summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/vyatta-cfg-system.postinst.in5
3 files changed, 12 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index b8128287..8b05318a 100644
--- a/debian/control
+++ b/debian/control
@@ -39,7 +39,8 @@ Depends: sed (>= 4.1.5),
dnsmasq,
mdadm,
ddclient,
- libio-socket-ssl-perl
+ libio-socket-ssl-perl,
+ pam-tacplus
Pre-Depends: bash-completion
Suggests: util-linux (>= 2.13-5),
net-tools,
diff --git a/debian/rules b/debian/rules
index 7955e31c..530a2145 100755
--- a/debian/rules
+++ b/debian/rules
@@ -88,7 +88,11 @@ binary-indep: build install
dh_compress
dh_fixperms
dh_installdeb
- dh_gencontrol
+ if [ -f "../.VYATTA_DEV_BUILD" ]; then \
+ dh_gencontrol -- -v999.dev; \
+ else \
+ dh_gencontrol; \
+ fi
dh_md5sums
dh_builddeb
diff --git a/debian/vyatta-cfg-system.postinst.in b/debian/vyatta-cfg-system.postinst.in
index 3304fdd8..0f699d2b 100644
--- a/debian/vyatta-cfg-system.postinst.in
+++ b/debian/vyatta-cfg-system.postinst.in
@@ -11,6 +11,11 @@ for init in ntp ssh snmpd openhpid vyatta-keepalived ipvsadm dnsmasq ddclient; d
update-rc.d -f ${init} remove >/dev/null
done
+# remove extra call to clock setup only need one
+if [ -L /etc/rcS.d/S08hwclockfirst.sh -a -L /etc/rcS.d/S11hwclock.sh ]; then
+ rm /etc/init.d/rcS.d/S11hwclock.sh
+fi
+
case `grep '^RULES_FILE=' /lib/udev/write_net_rules` in
*z25_persistent-net.rules* )
vyatta_net_rules=z24_vyatta-net.rules;;