summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-06-02 14:08:23 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-06-02 15:14:00 -0700
commitbf86040fef55fdb644b3670a9e1ec093e67df828 (patch)
tree0a216a4a9e21107326a20d538fe6f2fd2ba224dd
parentec47950ac719c65f0f195db6b73591640d9dd2be (diff)
downloadvyatta-cfg-system-bf86040fef55fdb644b3670a9e1ec093e67df828.tar.gz
vyatta-cfg-system-bf86040fef55fdb644b3670a9e1ec093e67df828.zip
Make Radius server work
Translate radius-server to Vyatta::Login::RadiusServer
-rw-r--r--Makefile.am2
-rw-r--r--lib/Vyatta/Login/RadiusServer.pm (renamed from lib/Vyatta/Login/Radius.pm)2
-rw-r--r--scripts/system/vyatta_update_login.pl2
3 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2168e11e..4a7e23a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,7 +44,7 @@ sbin_SCRIPTS += scripts/zone-mgmt/vyatta-zone.pl
sbin_SCRIPTS += scripts/vyatta-banner.pl
share_perl5_DATA = lib/Vyatta/Login/User.pm
-share_perl5_DATA += lib/Vyatta/Login/Radius.pm
+share_perl5_DATA += lib/Vyatta/Login/RadiusServer.pm
noinst_DATA = test_bootfile
diff --git a/lib/Vyatta/Login/Radius.pm b/lib/Vyatta/Login/RadiusServer.pm
index 6a949434..97ae4eb6 100644
--- a/lib/Vyatta/Login/Radius.pm
+++ b/lib/Vyatta/Login/RadiusServer.pm
@@ -14,7 +14,7 @@
#
# **** End License ****
-package Vyatta::Login::Radius;
+package Vyatta::Login::RadiusServer;
use strict;
use warnings;
use lib "/opt/vyatta/share/perl5";
diff --git a/scripts/system/vyatta_update_login.pl b/scripts/system/vyatta_update_login.pl
index b2125de1..b854427b 100644
--- a/scripts/system/vyatta_update_login.pl
+++ b/scripts/system/vyatta_update_login.pl
@@ -28,6 +28,8 @@ $config->setLevel("system login");
foreach my $type ($config->listNodes()) {
my $kind = ucfirst $type;
+ $kind =~ s/-server/Server/;
+
my $location = "Vyatta/Login/$kind.pm";
my $class = "Vyatta::Login::$kind";