summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStig Thormodsrud <stig@vyatta.com>2010-10-26 14:47:47 -0700
committerStig Thormodsrud <stig@vyatta.com>2010-10-26 14:47:47 -0700
commit7dc4ac0cb122bc98f903f93fc83e93007de7c751 (patch)
treeb5e4dedd12162bf134e37927b5197a2b64f1c347
parent427c67439359021ff5bb77929022748a99650f14 (diff)
downloadvyatta-cfg-system-7dc4ac0cb122bc98f903f93fc83e93007de7c751.tar.gz
vyatta-cfg-system-7dc4ac0cb122bc98f903f93fc83e93007de7c751.zip
Move config-mgmt to it's own package.
-rw-r--r--Makefile.am2
-rwxr-xr-xscripts/config-mgmt/vyatta-commit-push.pl85
-rwxr-xr-xscripts/config-mgmt/vyatta-config-mgmt.pl105
-rw-r--r--templates/system/config-mgmt/commit-uri/node.def24
-rw-r--r--templates/system/config-mgmt/node.def1
5 files changed, 0 insertions, 217 deletions
diff --git a/Makefile.am b/Makefile.am
index 4a050270..b4cfbe92 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,8 +57,6 @@ sbin_SCRIPTS += scripts/install/install-image
sbin_SCRIPTS += scripts/vyatta-bridgegroup-depedency.pl
sbin_SCRIPTS += scripts/vyatta-dhcpv6-client.pl
sbin_SCRIPTS += scripts/vyatta-update-grub.pl
-sbin_SCRIPTS += scripts/config-mgmt/vyatta-commit-push.pl
-sbin_SCRIPTS += scripts/config-mgmt/vyatta-config-mgmt.pl
share_perl5_DATA = lib/Vyatta/Login/User.pm
share_perl5_DATA += lib/Vyatta/Login/RadiusServer.pm
diff --git a/scripts/config-mgmt/vyatta-commit-push.pl b/scripts/config-mgmt/vyatta-commit-push.pl
deleted file mode 100755
index 1e16b811..00000000
--- a/scripts/config-mgmt/vyatta-commit-push.pl
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/usr/bin/perl
-#
-# **** License ****
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License version 2 as
-# published by the Free Software Foundation.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# A copy of the GNU General Public License is available as
-# `/usr/share/common-licenses/GPL' in the Debian GNU/Linux distribution
-# or on the World Wide Web at `http://www.gnu.org/copyleft/gpl.html'.
-# You can also obtain it by writing to the Free Software Foundation,
-# Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
-# MA 02110-1301, USA.
-#
-# This code was originally developed by Vyatta, Inc.
-# Portions created by Vyatta are Copyright (C) 2010 Vyatta, Inc.
-# All Rights Reserved.
-#
-# Author: Stig Thormodsrud
-# Date: October 2010
-# Description: Script to push cofig.boot to one or more URIs
-#
-# **** End License ****
-#
-
-use strict;
-use warnings;
-use lib '/opt/vyatta/share/perl5/';
-
-use Vyatta::Config;
-use POSIX;
-use File::Basename;
-use URI;
-
-
-my $debug = 0;
-
-my $config = new Vyatta::Config;
-
-$config->setLevel('system config-mgmt');
-
-my @uris = $config->returnOrigValues('commit-uri');
-
-if (scalar(@uris) < 1) {
- print "No URI's configured\n";
- exit 0;
-}
-
-my $upload_file = '/opt/vyatta/etc/config/config.boot';
-
-my $timestamp = strftime("_%Y%m%d_%H%M%S", localtime);
-my $same_file = basename($upload_file) . $timestamp;
-
-print "Archiving config...\n";
-foreach my $uri (@uris) {
- my $u = URI->new($uri);
- my $scheme = $u->scheme();
- my $auth = $u->authority();
- my $path = $u->path();
- my ($host, $remote) = ('', '');
- if (defined $auth and $auth =~ /.*\@(.*)/) {
- $host = $1;
- } else {
- $host = $auth if defined $auth;
- }
- $remote .= "$scheme://$host";
- $remote .= "$path" if defined $path;
-
- print " $remote ";
- my $cmd = "curl -s -T $upload_file $uri/$same_file";
- print "cmd [$cmd]\n" if $debug;
- my $rc = system($cmd);
- if ($rc eq 0) {
- print " OK\n";
- } else {
- print " failed\n";
- }
-}
-
-exit 0;
diff --git a/scripts/config-mgmt/vyatta-config-mgmt.pl b/scripts/config-mgmt/vyatta-config-mgmt.pl
deleted file mode 100755
index 8f434eb4..00000000
--- a/scripts/config-mgmt/vyatta-config-mgmt.pl
+++ /dev/null
@@ -1,105 +0,0 @@
-#!/usr/bin/perl
-#
-# **** License ****
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License version 2 as
-# published by the Free Software Foundation.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# A copy of the GNU General Public License is available as
-# `/usr/share/common-licenses/GPL' in the Debian GNU/Linux distribution
-# or on the World Wide Web at `http://www.gnu.org/copyleft/gpl.html'.
-# You can also obtain it by writing to the Free Software Foundation,
-# Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
-# MA 02110-1301, USA.
-#
-# This code was originally developed by Vyatta, Inc.
-# Portions created by Vyatta are Copyright (C) 2010 Vyatta, Inc.
-# All Rights Reserved.
-#
-# Author: Stig Thormodsrud
-# Date: October 2010
-# Description: Script to push cofig.boot to one or more URIs
-#
-# **** End License ****
-#
-
-use strict;
-use warnings;
-use lib '/opt/vyatta/share/perl5/';
-
-use Vyatta::Config;
-use Getopt::Long;
-use URI;
-
-my $commit_uri_script = '/opt/vyatta/sbin/vyatta-commit-push.pl';
-my $link_name = '/etc/commit/vyatta-commit-push.pl';
-
-my $debug = 0;
-
-#
-# main
-#
-my ($action, $uri);
-
-GetOptions("action=s" => \$action,
- "uri=s" => \$uri,
-);
-
-die "Error: no action" if ! defined $action;
-
-my ($cmd, $rc) = ('', 1);
-
-if ($action eq 'add-uri') {
- print "add-uri\n" if $debug;
- my $config = new Vyatta::Config;
- $config->setLevel('system config-mgmt');
- my @uris = $config->returnValues('commit-uri');
- if (scalar(@uris) >= 1 and ! -e $link_name) {
- print "add link\n" if $debug;
- $rc = system("ln -s $commit_uri_script $link_name");
- exit $rc;
- }
- exit 0;
-}
-
-if ($action eq 'del-uri') {
- print "del-uri\n" if $debug;
- my $config = new Vyatta::Config;
- $config->setLevel('system config-mgmt');
- my @uris = $config->returnValues('commit-uri');
- if (scalar(@uris) <= 0) {
- print "remove link\n" if $debug;
- $rc = system("rm -f $link_name");
- exit $rc;
- }
- exit 0;
-}
-
-if ($action eq 'valid-uri') {
- die "Error: no uri" if ! defined $uri;
- print "valid-uri [$uri]\n" if $debug;
- my $u = URI->new($uri);
- exit 1 if ! defined $u;
- my $scheme = $u->scheme();
- my $auth = $u->authority();
- my $path = $u->path();
-
- exit 1 if ! defined $scheme or ! defined $path;
- if ($scheme eq 'tftp') {
- } elsif ($scheme eq 'ftp') {
- } elsif ($scheme eq 'scp') {
- } else {
- print "Unsupported URI scheme\n";
- exit 1;
- }
- exit 0;
-}
-
-exit $rc;
-
-# end of file
diff --git a/templates/system/config-mgmt/commit-uri/node.def b/templates/system/config-mgmt/commit-uri/node.def
deleted file mode 100644
index 7b483f9f..00000000
--- a/templates/system/config-mgmt/commit-uri/node.def
+++ /dev/null
@@ -1,24 +0,0 @@
-multi:
-priority: 400
-type: txt
-help: Commit URI
-
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-config-mgmt.pl \
- --action=valid-uri \
- --uri=\"$VAR(@)\" "; "Invalid URI"
-
-create: if [ "$COMMIT_SIBLING_POSITION" = "LAST" ] || \
- [ "$COMMIT_SIBLING_POSITION" = "FIRSTLAST" ] ; then
- sudo ${vyatta_sbindir}/vyatta-config-mgmt.pl --action=add-uri
- fi;
-
-delete: if [ "$COMMIT_SIBLING_POSITION" = "LAST" ] || \
- [ "$COMMIT_SIBLING_POSITION" = "FIRSTLAST" ] ; then
- sudo ${vyatta_sbindir}/vyatta-config-mgmt.pl --action=del-uri
- fi;
-
-val_help: <uri> ; Uniform Resource Identifier
-comp_help:
- "scp://<user>:<passwd>@<host>/<dir>"
- "ftp://<user>:<passwd>@<host>/<dir>"
- "tftp://<host>/<dir>" \ No newline at end of file
diff --git a/templates/system/config-mgmt/node.def b/templates/system/config-mgmt/node.def
deleted file mode 100644
index 03a4d65a..00000000
--- a/templates/system/config-mgmt/node.def
+++ /dev/null
@@ -1 +0,0 @@
-help: Configuration management settings \ No newline at end of file