summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Gilligan <gilligan@vyatta.com>2011-05-17 08:45:03 -0700
committerBob Gilligan <gilligan@vyatta.com>2011-05-17 08:45:03 -0700
commit1878e70e862a0fdbd15d19eda5ac205e5d8742ba (patch)
tree2ac0c83a9202156113f3ce5ccf5fc5a97e33cda2
parent5110537e316c91bac34b420e427c352ead950da6 (diff)
parent20ea509416d58272d610d0390ef1bf9ce661bc50 (diff)
downloadvyatta-cfg-system-1878e70e862a0fdbd15d19eda5ac205e5d8742ba.tar.gz
vyatta-cfg-system-1878e70e862a0fdbd15d19eda5ac205e5d8742ba.zip
Merge branch 'napa' of http://git.vyatta.com/vyatta-cfg-system into napa
-rw-r--r--debian/changelog6
-rwxr-xr-xscripts/keepalived/vyatta-show-vrrp.pl2
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a14e3358..10840738 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg-system (0.19.79) unstable; urgency=low
+
+ * Fix 5912: "show vrrp" doesn't list sync-group
+
+ -- Stig Thormodsrud <stig@vyatta.com> Wed, 18 May 2011 12:25:33 -0700
+
vyatta-cfg-system (0.19.78) unstable; urgency=low
* irq-affinity: add workaround to avoid some cpu's
diff --git a/scripts/keepalived/vyatta-show-vrrp.pl b/scripts/keepalived/vyatta-show-vrrp.pl
index bcc6ca29..28a9970c 100755
--- a/scripts/keepalived/vyatta-show-vrrp.pl
+++ b/scripts/keepalived/vyatta-show-vrrp.pl
@@ -211,6 +211,7 @@ sub vrrp_show {
if ($state eq "master" || $state eq "backup" || $state eq "fault") {
my ($primary_addr, $priority, $preempt, $advert_int, $auth_type,
@vips) = Vyatta::Keepalived::vrrp_get_config($intf, $group);
+ my $sync = list_vrrp_sync_group($intf, $group);
print "Physical interface: $intf, Source Address $primary_addr\n";
print " Interface state: $link, Group $group, State: $state\n";
print " Priority: $priority, Advertisement interval: $advert_int, ";
@@ -240,6 +241,7 @@ sub vrrp_show {
}
print ", Master Priority: $master_prio\n";
}
+ print " Sync-group: $sync\n" if defined $sync;
} else {
print "Physical interface $intf, State: unknown\n";
}