summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <shemminger@vyatta.com>2011-08-05 20:55:40 -0700
committerStephen Hemminger <shemminger@vyatta.com>2011-08-05 20:55:40 -0700
commit48f3a8e8c8b19d1d96e409d2f57872b659b85331 (patch)
tree135351c5628b3b16851758ad6c1a06b8959eb6c2
parent8b49f93b06cfe494182c533dc00499abc8452660 (diff)
parent5c9468830faaad8976bf9739d250363aef171f40 (diff)
downloadvyatta-cfg-system-48f3a8e8c8b19d1d96e409d2f57872b659b85331.tar.gz
vyatta-cfg-system-48f3a8e8c8b19d1d96e409d2f57872b659b85331.zip
Merge branch 'oxnard' of fiji.vyatta.com:/git/vyatta-cfg-system into oxnard
-rw-r--r--debian/changelog43
-rw-r--r--debian/vyatta-cfg-system.postinst.in7
-rwxr-xr-xscripts/install/install-image-existing5
-rwxr-xr-xscripts/install/install-postinst-new24
-rwxr-xr-xscripts/vyatta-bonding.pl2
5 files changed, 74 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index cbeae26f..a7b07c9a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,46 @@
+vyatta-cfg-system (0.19.106) unstable; urgency=low
+
+ * Added to make "force" op-mode command accessible to user type
+
+ -- Deepti Kulkarni <deepti@vyatta.com> Wed, 27 Jul 2011 08:00:09 -0700
+
+vyatta-cfg-system (0.19.105) unstable; urgency=low
+
+ * Bugfix 7350: Allow default config.boot to be selected as config
+ file.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Wed, 17 Aug 2011 15:08:32 -0700
+
+vyatta-cfg-system (0.19.104) unstable; urgency=low
+
+ * Fix permission problems on /config during initial install
+
+ -- John Southworth <john.southworth@vyatta.com> Fri, 15 Jul 2011 20:49:15 -0700
+
+vyatta-cfg-system (0.19.103) unstable; urgency=low
+
+ * Bugfix 7070: Need to provide full path for irq-affinity.pl in
+ system()
+
+ -- Bob Gilligan <gilligan@vyatta.com> Sun, 14 Aug 2011 16:37:47 -0700
+
+vyatta-cfg-system (0.19.102) unstable; urgency=low
+
+ * Add hook to call a config migration script when upgrading from VSE
+ Demo.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Fri, 12 Aug 2011 17:30:00 -0700
+
+vyatta-cfg-system (0.19.101) unstable; urgency=low
+
+ [ Stephen Hemminger ]
+ * Fix duplicate detection of hypervisor
+
+ [ John Southworth ]
+ * Bugfix 7326: add /config/support directory by default
+
+ -- John Southworth <john.southworth@vyatta.com> Wed, 13 Jul 2011 15:56:08 -0500
+
vyatta-cfg-system (0.19.100) unstable; urgency=low
* new branch
diff --git a/debian/vyatta-cfg-system.postinst.in b/debian/vyatta-cfg-system.postinst.in
index 4648d29c..0eb74858 100644
--- a/debian/vyatta-cfg-system.postinst.in
+++ b/debian/vyatta-cfg-system.postinst.in
@@ -111,9 +111,11 @@ Cmnd_Alias DATE = /bin/date, /usr/sbin/ntpdate
Cmnd_Alias PPPOE_CMDS = /sbin/pppd, /sbin/poff, /usr/sbin/pppstats
Cmnd_Alias PCAPTURE = /usr/bin/tshark, /usr/bin/tcpdump
Cmnd_Alias HWINFO = /usr/bin/lspci
+Cmnd_Alias FORCE_CLUSTER = /usr/share/heartbeat/hb_takeover, \
+ /usr/share/heartbeat/hb_standby
%operator ALL=NOPASSWD: DATE, IPTABLES, ETHTOOL, IPFLUSH, HWINFO, \
PPPOE_CMDS, PCAPTURE, /usr/sbin/wanpipemon, \
- DISK, CONNTRACK, IP6TABLES
+ DISK, CONNTRACK, IP6TABLES, FORCE_CLUSTER
EOF
cat <<EOF >>/etc/sudoers
%users ALL=NOPASSWD: ${bindir}/sudo-users/
@@ -170,6 +172,9 @@ mkdir -p /var/core
mkdir -p /opt/vyatta/etc/config/auth
mkdir -p /opt/vyatta/etc/config/scripts
mkdir -p /opt/vyatta/etc/config/user-data
+mkdir -p /opt/vyatta/etc/config/support
+chown -R root.vyattacfg /opt/vyatta/etc/config
+chmod -R 775 /opt/vyatta/etc/config
# create /opt/vyatta/etc/config/scripts/vyatta-postconfig-bootup.script
# this should be after 'mkdir -p /opt/vyatta/etc/config/scripts' above
diff --git a/scripts/install/install-image-existing b/scripts/install/install-image-existing
index 94a0033b..7c75b35b 100755
--- a/scripts/install/install-image-existing
+++ b/scripts/install/install-image-existing
@@ -183,6 +183,8 @@ fi
space_needed_configdata=`du -s ${VYATTA_NEW_CFG_DIR} | awk '{ print $1 }'`
space_needed_config=$(($space_needed_configdata - $space_needed_data))
+DEMO_MIGRATE_SCRIPT=/opt/vyatta/sbin/demo-to-vse.pl
+
# save current config dir if needed
if [ $space_avail -gt $space_needed_configdata ]; then
resp=''
@@ -198,6 +200,9 @@ if [ $space_avail -gt $space_needed_configdata ]; then
-exec cp '-a' '{}' "$ndir/" ';'
chgrp -R vyattacfg $ndir
chmod -R 775 $ndir
+ if [ -x $DEMO_MIGRATE_SCRIPT ]; then
+ $DEMO_MIGRATE_SCRIPT $ndir/config.boot
+ fi
fi
done
else
diff --git a/scripts/install/install-postinst-new b/scripts/install/install-postinst-new
index c96f5657..0f7a9b61 100755
--- a/scripts/install/install-postinst-new
+++ b/scripts/install/install-postinst-new
@@ -39,9 +39,16 @@ copy_config () {
else
# Find the config files and give the user the option to copy config files
# TODO: this needs cleaned up
- if [ -f "${VYATTA_CFG_DIR}/config.boot" ]; then
- config=${VYATTA_CFG_DIR}/config.boot
+
+ # First candidate: The config file on the running system. Note
+ # that this will include any changes made and saved by the user,
+ # as well as changes such as interface MAC addresses automatically
+ # generated by the user. So it is the first choice.
+ if [ -f "${VYATTA_NEW_CFG_DIR}/config.boot" ]; then
+ config=${VYATTA_NEW_CFG_DIR}/config.boot
fi
+
+ # Second candidate: The config file on floppy, if one exists.
if [ -f "${FD_CFG_DIR}/config.boot" ]; then
if [ -z "$config" ]; then
config="${FD_CFG_DIR}/config.boot"
@@ -50,10 +57,16 @@ copy_config () {
fi
fi
+ # Third candidate: The default config file
+ DEF_CONF=$vyatta_sysconfdir/config.boot.default
+ if [ -f $DEF_CONF ]; then
+ config="$config $DEF_CONF"
+ fi
+
if [ -n "$config" ]; then
- echo "I found the following configuration files"
+ echo "I found the following configuration files:"
for file in $config; do
- echo $file
+ echo " $file"
done
default=$(echo -e $config | awk '{ print $1 }')
@@ -64,7 +77,8 @@ copy_config () {
done
echo
- cp -p $configfile $cfg_dir/ >&/dev/null
+ echo "Copying $configfile to $INSTALL_DRIVE."
+ cp -p $configfile $cfg_dir/config.boot >&/dev/null
if [ $? != 0 ]; then
lecho "Error copying file $configfile to config directory. Exiting..."
exit 1
diff --git a/scripts/vyatta-bonding.pl b/scripts/vyatta-bonding.pl
index 8cd8d5f0..eac89f07 100755
--- a/scripts/vyatta-bonding.pl
+++ b/scripts/vyatta-bonding.pl
@@ -155,7 +155,7 @@ sub if_up {
my $smp_affinity = get_irq_affinity($intf);
if ($smp_affinity) {
- system "irq-affinity.pl $intf $smp_affinity"
+ system "/opt/vyatta/sbin/irq-affinity.pl $intf $smp_affinity"
and warn "Could not set $intf smp_affinity $smp_affinity\n";
}
}