summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2011-07-20 11:26:37 -0500
committerJohn Southworth <john.southworth@vyatta.com>2011-07-20 11:26:37 -0500
commitab6d0b035f0dbf192496dc151c2d3db395dbbc7a (patch)
tree90b3fa4d24f29d34ba6d0ae6d539b13e4eb123d3
parent0d293224987a42025102c1e811f5ab3a9f4e88d2 (diff)
parent384ae6917b2d744b2557dda148b33e7e7adc0f48 (diff)
downloadvyatta-cfg-system-ab6d0b035f0dbf192496dc151c2d3db395dbbc7a.tar.gz
vyatta-cfg-system-ab6d0b035f0dbf192496dc151c2d3db395dbbc7a.zip
Merge branch 'oxnard' of git.vyatta.com:/git/vyatta-cfg-system into oxnard
-rw-r--r--debian/changelog13
-rwxr-xr-xscripts/install/install-postinst-new24
2 files changed, 32 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 2e13555f..84272269 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+vyatta-cfg-system (0.19.105) unstable; urgency=low
+
+ * Bugfix 7350: Allow default config.boot to be selected as config
+ file.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Wed, 17 Aug 2011 15:08:32 -0700
+
+vyatta-cfg-system (0.19.104) unstable; urgency=low
+
+ * Fix permission problems on /config during initial install
+
+ -- John Southworth <john.southworth@vyatta.com> Fri, 15 Jul 2011 20:49:15 -0700
+
vyatta-cfg-system (0.19.103) unstable; urgency=low
* Bugfix 7070: Need to provide full path for irq-affinity.pl in
diff --git a/scripts/install/install-postinst-new b/scripts/install/install-postinst-new
index c96f5657..0f7a9b61 100755
--- a/scripts/install/install-postinst-new
+++ b/scripts/install/install-postinst-new
@@ -39,9 +39,16 @@ copy_config () {
else
# Find the config files and give the user the option to copy config files
# TODO: this needs cleaned up
- if [ -f "${VYATTA_CFG_DIR}/config.boot" ]; then
- config=${VYATTA_CFG_DIR}/config.boot
+
+ # First candidate: The config file on the running system. Note
+ # that this will include any changes made and saved by the user,
+ # as well as changes such as interface MAC addresses automatically
+ # generated by the user. So it is the first choice.
+ if [ -f "${VYATTA_NEW_CFG_DIR}/config.boot" ]; then
+ config=${VYATTA_NEW_CFG_DIR}/config.boot
fi
+
+ # Second candidate: The config file on floppy, if one exists.
if [ -f "${FD_CFG_DIR}/config.boot" ]; then
if [ -z "$config" ]; then
config="${FD_CFG_DIR}/config.boot"
@@ -50,10 +57,16 @@ copy_config () {
fi
fi
+ # Third candidate: The default config file
+ DEF_CONF=$vyatta_sysconfdir/config.boot.default
+ if [ -f $DEF_CONF ]; then
+ config="$config $DEF_CONF"
+ fi
+
if [ -n "$config" ]; then
- echo "I found the following configuration files"
+ echo "I found the following configuration files:"
for file in $config; do
- echo $file
+ echo " $file"
done
default=$(echo -e $config | awk '{ print $1 }')
@@ -64,7 +77,8 @@ copy_config () {
done
echo
- cp -p $configfile $cfg_dir/ >&/dev/null
+ echo "Copying $configfile to $INSTALL_DRIVE."
+ cp -p $configfile $cfg_dir/config.boot >&/dev/null
if [ $? != 0 ]; then
lecho "Error copying file $configfile to config directory. Exiting..."
exit 1