summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <shemminger@vyatta.com>2011-11-29 09:38:02 -0800
committerStephen Hemminger <shemminger@vyatta.com>2011-11-29 09:38:02 -0800
commit3cda57eb4059089eaf3d8902d8d336ad747092ea (patch)
treeae86ec70b965748aab11a44fc3674edb5781d935
parentfb20f9b3c08ac1e523ee2f0d4b4af9dc3fcbfc04 (diff)
parent1388d7fbdbc9533ca4bfb98cfe812fa67bd33342 (diff)
downloadvyatta-cfg-system-3cda57eb4059089eaf3d8902d8d336ad747092ea.tar.gz
vyatta-cfg-system-3cda57eb4059089eaf3d8902d8d336ad747092ea.zip
Merge branch 'oxnard' of fiji.vyatta.com:/git/vyatta-cfg-system into oxnard
-rw-r--r--debian/changelog6
-rwxr-xr-xscripts/keepalived/vyatta-show-vrrp.pl6
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0ad2c1b5..a37a7d1a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg-system (0.19.131) unstable; urgency=low
+
+ * Display vmac interface name in "show vrrp interfaces ..." command
+
+ -- Bob Gilligan <gilligan@vyatta.com> Mon, 28 Nov 2011 18:06:04 -0800
+
vyatta-cfg-system (0.19.130) unstable; urgency=low
* Support VRRP virtual MAC interfaces above bond and bond vif
diff --git a/scripts/keepalived/vyatta-show-vrrp.pl b/scripts/keepalived/vyatta-show-vrrp.pl
index 28a9970c..68a98390 100755
--- a/scripts/keepalived/vyatta-show-vrrp.pl
+++ b/scripts/keepalived/vyatta-show-vrrp.pl
@@ -188,6 +188,7 @@ sub vrrp_showsummary {
my ($interface_state, $link) = get_state_link($intf);
if ($state eq "master" || $state eq "backup" || $state eq "fault") {
my ($primary_addr, $priority, $preempt, $advert_int, $auth_type,
+ $vmac_interface,
@vips) = Vyatta::Keepalived::vrrp_get_config($intf, $group);
my $format = "\n%-16s%-8s%-8s%-16s%-16s%-16s";
my $vip = shift @vips;
@@ -210,9 +211,14 @@ sub vrrp_show {
my $first_vip = '';
if ($state eq "master" || $state eq "backup" || $state eq "fault") {
my ($primary_addr, $priority, $preempt, $advert_int, $auth_type,
+ $vmac_interface,
@vips) = Vyatta::Keepalived::vrrp_get_config($intf, $group);
my $sync = list_vrrp_sync_group($intf, $group);
print "Physical interface: $intf, Source Address $primary_addr\n";
+ if ($vmac_interface) {
+ my $vma = "$intf" . "v" . "$group";
+ print " Virtual MAC interface: $vma\n";
+ }
print " Interface state: $link, Group $group, State: $state\n";
print " Priority: $priority, Advertisement interval: $advert_int, ";
print "Authentication type: $auth_type\n";