summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrbalocca <rbalocca@vyatta.com>2008-08-01 18:11:09 -0700
committerrbalocca <rbalocca@vyatta.com>2008-08-01 18:11:09 -0700
commita34c2884bc159d0473ff99f3fccd468fab285726 (patch)
tree819701c50a4d7acb5feeac9950c8255aa4b76a94
parentc4035aa5d0601eaa2a64d67ca70326f4de3873e8 (diff)
downloadvyatta-cfg-system-a34c2884bc159d0473ff99f3fccd468fab285726.tar.gz
vyatta-cfg-system-a34c2884bc159d0473ff99f3fccd468fab285726.zip
Fixes for: http://bugzilla.vyatta.com/show_bug.cgi?id=3520 http://bugzilla.vyatta.com/show_bug.cgi?id=3519 http://bugzilla.vyatta.com/show_bug.cgi?d for: http://bugzilla.vyatta.com/show_bug.cgi?id=3520 http://bugzilla.vyatta.com/show_bug.cgi?id=3519 http://bugzilla.vyatta.com/show_bug.cgi?id=3518 and perhaps others
-rw-r--r--Makefile.am1
-rwxr-xr-xscripts/grub-setup180
-rwxr-xr-xscripts/install-system129
3 files changed, 190 insertions, 120 deletions
diff --git a/Makefile.am b/Makefile.am
index 742f9025..576be4be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,6 +15,7 @@ bin_SCRIPTS += scripts/vyatta-functions
sbin_SCRIPTS += scripts/init-floppy
sbin_SCRIPTS += scripts/rl-system.init
sbin_SCRIPTS += scripts/install-system
+sbin_SCRIPTS += scripts/grub-setup
sbin_SCRIPTS += scripts/quick-install
sbin_SCRIPTS += scripts/standalone_root_pw_reset
sbin_SCRIPTS += scripts/vyatta-passwd-sync
diff --git a/scripts/grub-setup b/scripts/grub-setup
new file mode 100755
index 00000000..115df53d
--- /dev/null
+++ b/scripts/grub-setup
@@ -0,0 +1,180 @@
+#!/bin/sh -x
+#
+# Module: grup-setup
+#
+# **** License ****
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 as
+# published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# This code was originally developed by Vyatta, Inc.
+# Portions created by Vyatta are Copyright (C) 2006, 2007 Vyatta, Inc.
+# All Rights Reserved.
+#
+# Author: Robert Bays
+# Date: 2006
+# Description:
+#
+# **** End License ****
+#
+# Vyatta grub customization setup script.
+#
+#
+
+ROOT_PARTITION="$1"
+GRUB_OPTIONS="$2"
+ROOTFSDIR="$3"
+
+[ "$GRUB_OPTIONS" -a "$ROOT_PARTITION" ] || exit 1
+
+# Grub options
+GRUB_OPTIONS="$GRUB_OPTIONS quiet"
+
+# Path to standalone root password reset script
+pass_reset=/opt/vyatta/sbin/standalone_root_pw_reset
+
+# Output to both console (last device is /dev/console)
+vty_console="console=ttyS0,9600 console=tty0"
+serial_console="console=tty0 console=ttyS0,9600"
+
+# If vga_logo is set, enable use of the VGA monitor for displaying the
+# logo during boot. The "vga=" boot command specifies a VGA mode that
+# is encoded as shown below. We pick a value that is likely to work
+# on most systems:
+#
+# Color depth | 640x480 | 800x600 | 1024x768 | 1280x1024
+# -----------------+---------+---------+----------+----------
+# 256 (8bit) | 769 771 773 775
+# 32000 (15bit) | 784 787 790 793
+# 65000 (16bit) | 785 788 791 794
+# 16.7 Mill.(24bit)| 786 789 792 795
+#
+vga_logo="vga=788"
+
+ # TODO: This needs to be changed to map to the correct drive
+ part=$(echo ${ROOT_PARTITION} | sed 's/[^0-9]//g')
+ if [ "$(cat /sys/block/$ORIG_INSTALL_DRIVE/removable)" == 0 ]; then
+ root=$(grep $ORIG_INSTALL_DRIVE $ROOTFSDIR/boot/grub/device.map | /usr/bin/awk -F')' '{ print $1 }')
+ root="$root,$part)"
+ else
+ root="(hd0,$part)"
+ echo "This looks like a removable device. Setting root grub device to $root."
+ fi
+
+ # get list of kernels, except Xen
+ kernel_versions=$(ls /boot/vmlinuz-* 2> /dev/null | grep -v xen | sed 's:/boot/vmlinuz::g' | sort -r)
+
+ # get xen kernel info
+ xen_kernel_version=$(ls /boot/vmlinuz*xen 2> /dev/null | sed 's:/boot/vmlinuz::g' | sort -r)
+ xen_version=$(ls /boot/ | grep xen- | sort -r)
+
+ # Figure out whether we are running on the serial or KVM console:
+ if [ "`tty`" == "/dev/ttyS0" ]; then
+ # Since user is running on serial console, make that the default.
+ default_console=1
+ else
+ # Since user is running on KVM console, make that the default
+ default_console=0
+ fi
+
+ # Read UUID off of filesystem and use it to tell GRUB where to mount drive
+ # This allows device to move around and grub will still find it
+ uuid=$(dumpe2fs -h /dev/${ROOT_PARTITION} 2>/dev/null | awk '/^Filesystem UUID/ {print $3}')
+ if [ -z "$uuid" ]
+ then
+ # TODO: use /proc/mount if dumpe2fs fails
+ echo "Unable to read filesystem UUID. Exiting."
+ exit 1
+ else
+ grub_root="root=UUID=$uuid ro"
+ fi
+
+(
+ # create the grub.cfg file for grub
+ # The "default=" line selects which boot option will be used by default.
+ # Numbering starts at 0 for the first option.
+ echo -e "set default=$default_console"
+ echo "set timeout=5"
+ #echo "#set splashimage=(hd0,0)/grub/splash.xpm.gz"
+ # set serial console options
+ echo -e "serial --unit=0 --speed=9600"
+ echo "terminal serial"
+ echo "set root=$root"
+
+ echo ""
+ echo "echo -n Press ESC to enter the Grub menu..."
+ echo "if sleep --verbose --interruptible 5 ; then"
+ echo -e "\tterminal console"
+ echo -e "\techo -n Press the ESC key to enter the Grub menu..."
+ echo -e "\tif sleep --verbose --interruptible 5 ; then"
+ echo -e "\t\tterminal serial"
+ echo -e "\t\tset timeout=0"
+ echo -e "\tfi"
+ echo "fi"
+ echo ""
+
+ if [ -f "/boot/vmlinuz" ]; then
+ # Set first system boot option. Make KVM the default console in this one.
+ echo -e "menuentry \"Vyatta OFR (KVM console)\" {"
+ echo -e "\tlinux /boot/vmlinuz $grub_root $GRUB_OPTIONS $vga_logo $vty_console"
+ echo -e "\tinitrd /boot/initrd.img"
+ echo -e "}"
+
+ # Set the second system boot option. Make the serial port be the default
+ # console in this one.
+ echo
+ echo -e "menuentry \"Vyatta OFR (Serial console)\" {"
+ echo -e "\tlinux /boot/vmlinuz $grub_root $GRUB_OPTIONS $serial_console"
+ echo -e "\tinitrd /boot/initrd.img"
+ echo -e "}"
+ fi
+
+ # create xen kernels if they exist
+ if [ -n "$xen_kernel_version" ]; then
+ for xversion in $xen_kernel_version; do
+ echo
+ echo
+ echo -e "menuentry \"Vyatta Xen linux$xversion dom0\" {"
+ echo -e "\tmultiboot /boot/$xen_version "
+ echo -e "\tmodule /boot/vmlinuz$xversion $grub_root $GRUB_OPTIONS $vty_console"
+ echo -e "\tmodule /boot/initrd.img$xversion"
+ echo -e "}"
+ done
+ fi
+
+ # create other kernels if they exist
+ if [ -n "$kernel_versions" ]; then
+ for kversion in $kernel_versions; do
+ echo
+ echo -e "menuentry \"Vyatta OFR linux$kversion (KVM console)\" {"
+ echo -e "\tlinux /boot/vmlinuz$kversion $grub_root $GRUB_OPTIONS $vty_console"
+ echo -e "\tinitrd /boot/initrd.img$kversion"
+ echo -e "}"
+ echo
+ echo -e "menuentry \"Vyatta OFR linux$kversion (Serial console)\" {"
+ echo -e "\tlinux /boot/vmlinuz$kversion $grub_root $GRUB_OPTIONS $serial_console"
+ echo -e "\tinitrd /boot/initrd.img$kversion"
+ echo -e "}"
+ done
+ fi
+
+ # Set options for root password reset. Offer
+ # options for both serial and KVM console.
+
+ echo
+ echo -e "menuentry \"Root password reset to factory (KVM console)\" {"
+ echo -e "\tlinux /boot/vmlinuz $grub_root $GRUB_OPTIONS $vty_console init=$pass_reset"
+ echo -e "\tinitrd /boot/initrd.img"
+ echo -e "}"
+
+ echo
+ echo -e "menuentry \"Root password reset to factory (Serial console)\" {"
+ echo -e "\tlinux /boot/vmlinuz $grub_root $GRUB_OPTIONS $serial_console init=$pass_reset"
+ echo -e "\tinitrd /boot/initrd.img"
+ echo -e "}"
+) >"$ROOTFSDIR"/boot/grub/grub.cfg
diff --git a/scripts/install-system b/scripts/install-system
index d6ea9b74..a704d4a7 100755
--- a/scripts/install-system
+++ b/scripts/install-system
@@ -612,131 +612,20 @@ install_grub () {
grub-install --no-floppy --root-directory=$rootfsdir /dev/$INSTALL_DRIVE >>$INSTALL_LOG 2>&1
progress_indicator stop
- # TODO: This needs to be changed to map to the correct drive
- part=$(echo $ROOT_PARTITION | sed 's/[^0-9]//g')
- if [ "$(cat /sys/block/$orig_install_drive/removable)" == 0 ]; then
- root=$(grep $orig_install_drive $rootfsdir/boot/grub/device.map | /usr/bin/awk -F')' '{ print $1 }')
- root="$root,$part)"
- else
- root="(hd0,$part)"
- echo "This looks like a removable device. Setting root grub device to $root."
- echo "This looks like a removable device. Setting root grub device to $root." >> $INSTALL_LOG
- fi
-
- # get list of kernels, except Xen
- kernel_versions=$(ls /boot/vmlinuz-* 2> /dev/null | grep -v xen | sed 's:/boot/vmlinuz::g' | sort -r)
-
- # get xen kernel info
- xen_kernel_version=$(ls /boot/vmlinuz*xen 2> /dev/null | sed 's:/boot/vmlinuz::g' | sort -r)
- xen_version=$(ls /boot/ | grep xen- | sort -r)
-
- # Figure out whether we are running on the serial or KVM console:
- if [ "`tty`" == "/dev/ttyS0" ]; then
- # Since user is running on serial console, make that the default.
- DEFAULT_CONSOLE="1"
- else
- # Since user is running on KVM console, make that the default
- DEFAULT_CONSOLE="0"
+ # Assume no dma if the disk is smaller than 10G (such as a CF drive)
+ size=$(get_drive_size $INSTALL_DRIVE)
+ if [[ $size -lt 11000 && ! $grub_options =~ 'ide=nodma' ]]
+ then
+ grub_options="ide=nodma"
fi
- # Read UUID off of filesystem and use it to tell GRUB where to mount drive
- # This allows device to move around and grub will still find it
- local rootdev="/dev/$ROOT_PARTITION";
- uuid=$(dumpe2fs -h $rootdev 2>/dev/null | awk '/^Filesystem UUID/ {print $3}')
- if [ -z "$uuid" ]
+ if /opt/vyatta/sbin/grub-setup "$ROOT_PARTITION" "$grub_options" /mnt/rootfs >>$INSTALL_LOG
then
- echo "Unable to read filesystem UUID. Exiting."
- exit 1
+ echo "OK"
else
- GRUB_ROOT="root=UUID=$uuid ro"
+ echo Grub failed to install!
+ exit 1
fi
-
- (
- # create the grub.cfg file for grub
- # The "default=" line selects which boot option will be used by default.
- # Numbering starts at 0 for the first option.
- echo -e "set default=$DEFAULT_CONSOLE"
- echo "set timeout=5"
- #echo "#set splashimage=(hd0,0)/grub/splash.xpm.gz"
- # set serial console options
- echo -e "serial --unit=0 --speed=9600"
- echo "terminal serial"
- echo "set root=$root"
-
- echo ""
- echo "echo -n Press ESC to enter the Grub menu..."
- echo "if sleep --verbose --interruptible 5 ; then"
- echo -e "\tterminal console"
- echo -e "\techo -n Press the ESC key to enter the Grub menu..."
- echo -e "\tif sleep --verbose --interruptible 5 ; then"
- echo -e "\t\tterminal serial"
- echo -e "\t\tset timeout=0"
- echo -e "\tfi"
- echo "fi"
- echo ""
-
- if [ -f "/boot/vmlinuz" ]; then
- # Set first system boot option. Make KVM the default console in this one.
- echo -e "menuentry \"Vyatta OFR (KVM console)\" {"
- echo -e "\tlinux /boot/vmlinuz $GRUB_ROOT $GRUB_OPTIONS $VGA_LOGO $VTY_CONSOLE"
- echo -e "\tinitrd /boot/initrd.img"
- echo -e "}"
-
- # Set the second system boot option. Make the serial port be the default
- # console in this one.
- echo
- echo -e "menuentry \"Vyatta OFR (Serial console)\" {"
- echo -e "\tlinux /boot/vmlinuz $GRUB_ROOT $GRUB_OPTIONS $SERIAL_CONSOLE"
- echo -e "\tinitrd /boot/initrd.img"
- echo -e "}"
- fi
-
- # create xen kernels if they exist
- if [ -n "$xen_kernel_version" ]; then
- for xversion in $xen_kernel_version; do
- echo
- echo
- echo -e "menuentry \"Vyatta Xen linux$xversion dom0\" {"
- echo -e "\tmultiboot /boot/$xen_version "
- echo -e "\tmodule /boot/vmlinuz$xversion $GRUB_ROOT $GRUB_OPTIONS $VTY_CONSOLE"
- echo -e "\tmodule /boot/initrd.img$xversion"
- echo -e "}"
- done
- fi
-
- # create other kernels if they exist
- if [ -n "$kernel_versions" ]; then
- for kversion in $kernel_versions; do
- echo
- echo -e "menuentry \"Vyatta OFR linux$kversion (KVM console)\" {"
- echo -e "\tlinux /boot/vmlinuz$kversion $GRUB_ROOT $GRUB_OPTIONS $VTY_CONSOLE"
- echo -e "\tinitrd /boot/initrd.img$kversion"
- echo -e "}"
- echo
- echo -e "menuentry \"Vyatta OFR linux$kversion (Serial console)\" {"
- echo -e "\tlinux /boot/vmlinuz$kversion $GRUB_ROOT $GRUB_OPTIONS $SERIAL_CONSOLE"
- echo -e "\tinitrd /boot/initrd.img$kversion"
- echo -e "}"
- done
- fi
-
- # Set options for root password reset. Offer
- # options for both serial and KVM console.
-
- echo
- echo -e "menuentry \"Root password reset to factory (KVM console)\" {"
- echo -e "\tlinux /boot/vmlinuz $GRUB_ROOT $GRUB_OPTIONS $VTY_CONSOLE init=$PWRESET"
- echo -e "\tinitrd /boot/initrd.img"
- echo -e "}"
-
- echo
- echo -e "menuentry \"Root password reset to factory (Serial console)\" {"
- echo -e "\tlinux /boot/vmlinuz $GRUB_ROOT $GRUB_OPTIONS $SERIAL_CONSOLE init=$PWRESET"
- echo -e "\tinitrd /boot/initrd.img"
- echo -e "}"
- ) >"$rootfsdir/boot/grub/grub.cfg"
-
- echo "OK"
}
# ask for user input on the parted and skip setup methods