summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Gilligan <gilligan@vyatta.com>2011-01-17 19:43:14 -0800
committerBob Gilligan <gilligan@vyatta.com>2011-01-17 19:48:41 -0800
commit507d28da53a8a40ef70a23031d06a2ec823fef64 (patch)
treec3dc513b5ab13ddd06f690b837660d9bfa853cc7
parentf552fc4a528cdbd5f232da41199fbfbc94078f57 (diff)
downloadvyatta-cfg-system-507d28da53a8a40ef70a23031d06a2ec823fef64.tar.gz
vyatta-cfg-system-507d28da53a8a40ef70a23031d06a2ec823fef64.zip
Bugfix 6668: Check to see if log files need rotation hourly.
Previously, log file rotation was checked by cron daily. Some log file -- such as those generated by PPP -- can grow rapidly. Such infrequent checking can lead to running out of disk space on systems with small disk drives or flash storage. This change checks for rotation hourly. (cherry picked from commit 71a31ff516ef63f5ce52ca1bca17e10497a6a15d)
-rw-r--r--Makefile.am3
-rw-r--r--sysconf/vyatta-logrotate-hourly5
2 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ee53e446..501c8005 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,6 +99,9 @@ udevrulesdir = /lib/udev/rules.d
libudev_SCRIPTS = scripts/vyatta_net_name
udevrules_DATA = sysconf/65-vyatta-net.rules
+cronhourlydir = /etc/cron.hourly
+cronhourly_SCRIPTS = sysconf/vyatta-logrotate-hourly
+
rsyslogdir = /etc/rsyslog.d
rsyslog_DATA = sysconf/vyatta-log.conf
diff --git a/sysconf/vyatta-logrotate-hourly b/sysconf/vyatta-logrotate-hourly
new file mode 100644
index 00000000..055b4d5f
--- /dev/null
+++ b/sysconf/vyatta-logrotate-hourly
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+test -x /usr/sbin/logrotate || exit 0
+/usr/sbin/logrotate /etc/logrotate.conf
+