summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2012-02-29 22:55:45 +0000
committerJohn Southworth <john.southworth@vyatta.com>2012-02-29 22:55:45 +0000
commitd1fff3cab23fec182b70aba6589e475ec208d6e6 (patch)
tree0510482681330b177ce209a4a4db043628e6b0ae
parent82b0bced0463c33ef48d8268072940a36ce04d68 (diff)
parent90d8a2731ab6739abf3f8faae01dd16eea4c5ece (diff)
downloadvyatta-cfg-system-d1fff3cab23fec182b70aba6589e475ec208d6e6.tar.gz
vyatta-cfg-system-d1fff3cab23fec182b70aba6589e475ec208d6e6.zip
Merge branch 'oxnard' of git.vyatta.com:/git/vyatta-cfg-system into oxnard
-rw-r--r--debian/changelog30
-rw-r--r--debian/vyatta-cfg-system.postinst.in3
-rwxr-xr-xscripts/init-floppy4
-rwxr-xr-xscripts/install/install-image6
-rwxr-xr-xscripts/rl-system.init3
-rwxr-xr-xscripts/system/vyatta_update_ntp.pl2
6 files changed, 42 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 38537580..99e4567c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,33 @@
+vyatta-cfg-system (0.19.171) unstable; urgency=low
+
+ * Cleanup interface statistic clear files on reboot
+
+ -- Stephen Hemminger <shemminger@vyatta.com> Tue, 21 Feb 2012 21:22:56 -0800
+
+vyatta-cfg-system (0.19.170) unstable; urgency=low
+
+ * Fix server property option
+
+ -- Stephen Hemminger <shemminger@vyatta.com> Tue, 21 Feb 2012 13:20:52 -0800
+
+vyatta-cfg-system (0.19.169) unstable; urgency=low
+
+ * Disable reboot on ctrl-alt-del
+
+ -- Stephen Hemminger <shemminger@vyatta.com> Tue, 21 Feb 2012 12:23:28 -0800
+
+vyatta-cfg-system (0.19.168) unstable; urgency=low
+
+ * Remove reference to init-floppy
+
+ -- Stephen Hemminger <shemminger@vyatta.com> Tue, 21 Feb 2012 11:09:38 -0800
+
+vyatta-cfg-system (0.19.167) unstable; urgency=low
+
+ * Fix spelling errors in install image
+
+ -- Stephen Hemminger <shemminger@vyatta.com> Tue, 21 Feb 2012 10:56:55 -0800
+
vyatta-cfg-system (0.19.166) unstable; urgency=low
* Bug #7787: Allow using custom command line arguments in transition
diff --git a/debian/vyatta-cfg-system.postinst.in b/debian/vyatta-cfg-system.postinst.in
index 2d028c8f..36644e7a 100644
--- a/debian/vyatta-cfg-system.postinst.in
+++ b/debian/vyatta-cfg-system.postinst.in
@@ -198,6 +198,9 @@ if [ -e /etc/default/mdadm ]; then
sed -i 's/^START_DAEMON.*$/START_DAEMON=false/' /etc/default/mdadm
fi
+# Disable reboot on ctrl-alt-delete
+sed -i -e '/^ca/s/\/sbin\/shutdown .*$/\/bin\/echo "Ctrl\-Alt\-Del disabled."/' /etc/inittab
+
# remove unnecessary ddclient script in /etc/ppp/ip-up.d/
# this logs unnecessary messages trying to start ddclient
rm -f /etc/ppp/ip-up.d/ddclient
diff --git a/scripts/init-floppy b/scripts/init-floppy
index 9f5301d8..1ae0d79b 100755
--- a/scripts/init-floppy
+++ b/scripts/init-floppy
@@ -35,7 +35,7 @@ failure ()
exit 1
}
-# Look and see if we have a floopy drive
+# Look and see if we have a floppy drive
if sed -n '/[0-9]\+ fd$/ { q 1 }' /proc/devices || [ ! -e $DRIVE ] ; then
failure "No floppy device"
fi
@@ -55,7 +55,7 @@ unbind__error="\rError: Couldn't unbind ${vyatta_sysconfdir}/config."
umount_notice="\rAttempting to unmount floppy...\c"
umount__error="\rError: Couldn't unmount $DRIVE."
format_notice="\rFormatting floppy $DRIVE... \c"
-format__error="\rPlease insert a floppy disk in $DRIVE and rerun init-floppy."
+format__error="\rPlease insert a floppy disk in $DRIVE and rerun."
create_notice="\rCreating file system... \c"
create__error="\rError: Couldn't create filesystem on floppy $DRIVE"
mount__notice="\rMounting formatted floppy... \c"
diff --git a/scripts/install/install-image b/scripts/install/install-image
index 57730611..3cce1a15 100755
--- a/scripts/install/install-image
+++ b/scripts/install/install-image
@@ -100,7 +100,7 @@ fetch_iso_by_url ()
exit 1
fi
- echo "ISO download suceeded."
+ echo "ISO download succeeded."
echo "Checking for digital signature file..."
curl "$client_hdr" "$vers_hdr" $auth -f -o ${filename}.asc ${NEW_ISO}.asc
@@ -129,7 +129,7 @@ fetch_iso_by_url ()
fail_exit 'OK. Installation will not be performed.'
fi
- echo "OK. Proceding with installation anyway."
+ echo "OK. Proceeding with installation anyway."
else
echo "Digital signature is valid."
fi
@@ -186,7 +186,7 @@ set_up_new_iso ()
else
echo "Failed!"
echo "$failures checksum failures found!"
- echo "ISO image is correupted and can not be used."
+ echo "ISO image is corrupted and can not be used."
exit 1
fi
diff --git a/scripts/rl-system.init b/scripts/rl-system.init
index 20534897..fac5fbc1 100755
--- a/scripts/rl-system.init
+++ b/scripts/rl-system.init
@@ -216,6 +216,9 @@ start () {
## Clear out apt config file--it will be filled in by config load
empty /etc/apt/sources.list
+
+ # remove any interface stat clears
+ rm -f /var/run/vyatta/*.stats
}
case "$ACTION" in
diff --git a/scripts/system/vyatta_update_ntp.pl b/scripts/system/vyatta_update_ntp.pl
index 4619b3bc..a162f858 100755
--- a/scripts/system/vyatta_update_ntp.pl
+++ b/scripts/system/vyatta_update_ntp.pl
@@ -33,7 +33,7 @@ $cfg->setLevel("system ntp");
foreach my $server ($cfg->listNodes("server")) {
print "server $server iburst";
for my $property (qw(dynamic noselect preempt prefer)) {
- print " $property" if ($cfg->exists("$server $property"));
+ print " $property" if ($cfg->exists("server $server $property"));
}
print "\n";
}