summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2007-11-15 11:02:53 -0800
committerAn-Cheng Huang <ancheng@vyatta.com>2007-11-15 11:02:53 -0800
commitf50d376954e29731a1577b94f52193a13059d047 (patch)
treec6b28e252762eab88ad7337d9dd0ef8ef6b19edf
parent0d6807dac3d72fdfb98f42cac17dc1431a7fbdff (diff)
downloadvyatta-cfg-system-f50d376954e29731a1577b94f52193a13059d047.tar.gz
vyatta-cfg-system-f50d376954e29731a1577b94f52193a13059d047.zip
users added through our CLI now use "vbash" (from vyatta-bash package).
-rw-r--r--debian/control3
-rwxr-xr-xscripts/system/vyatta_update_login_user.pl3
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 13652305..88938b4a 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,8 @@ Depends: bash (>= 3.1),
perl (>= 5.8.8),
procps (>= 1:3.2.7-3),
coreutils (>= 5.97-5.3),
- vyatta-cfg, sysv-rc, ifrename, ntp, sysklogd, busybox, ssh, whois, sudo, snmpd, keepalived
+ vyatta-cfg, sysv-rc, ifrename, ntp, sysklogd, busybox, ssh, whois, sudo,
+ snmpd, keepalived, vyatta-bash
Suggests: util-linux (>= 2.13-5),
net-tools,
ethtool,
diff --git a/scripts/system/vyatta_update_login_user.pl b/scripts/system/vyatta_update_login_user.pl
index b246cee6..d84ee4b0 100755
--- a/scripts/system/vyatta_update_login_user.pl
+++ b/scripts/system/vyatta_update_login_user.pl
@@ -145,7 +145,8 @@ exit 4 if (!defined($user) || !defined($full) || !defined($encrypted)
exit 4 if (!defined($group_map{$group}));
$group = $group_map{$group};
-my $DEF_SHELL = "/bin/bash";
+# note that DEF_SHELL doesn't affect root since root is never "added"
+my $DEF_SHELL = "/bin/vbash";
open(GRP, "/etc/group") or exit 5;
my $def_gid = undef;