summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-11-22 09:33:38 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-11-22 10:42:26 -0800
commitcb55706633bda6c5bd7c8391da9193ad0146002b (patch)
tree236d75d4f3a7a2911f3609eb0f983f1e189f53ea /Makefile.am
parentfb1bf8a2eefbdb467a948688ab388628455ef480 (diff)
downloadvyatta-cfg-system-cb55706633bda6c5bd7c8391da9193ad0146002b.tar.gz
vyatta-cfg-system-cb55706633bda6c5bd7c8391da9193ad0146002b.zip
Add utilities checking addresses
These are new C language utilites to replace the Perl utility when checking interface addresses. Perl compilation is major component of slow boot time. Note: this changes the package from pure scripts (arch independent) to arch dependent
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d4175c6..a2635328 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,12 @@ sbin_SCRIPTS += scripts/vyatta-bridgegroup-depedency.pl
sbin_SCRIPTS += scripts/vyatta-dhcpv6-client.pl
sbin_SCRIPTS += scripts/vyatta-update-grub.pl
+sbin_PROGRAMS = src/valid_address
+sbin_PROGRAMS += src/local_ip
+
+src_valid_address = src/valid_address.c
+src_local_ip = src/local_ip.c
+
share_perl5_DATA = lib/Vyatta/Login/User.pm
share_perl5_DATA += lib/Vyatta/Login/RadiusServer.pm