summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMohit Mehta <mohit@vyatta.com>2011-04-18 18:00:48 -0700
committerMohit Mehta <mohit@vyatta.com>2011-04-18 18:00:48 -0700
commit4d5862053ef2f99d09507b2e9b702aca1229099a (patch)
treea3be28fccf256210728f675c0f366fdfc6eebcfa /Makefile.am
parent2b7d3fef5077dbc28e39ddb6a267fe6ddeb5813b (diff)
downloadvyatta-cfg-system-4d5862053ef2f99d09507b2e9b702aca1229099a.tar.gz
vyatta-cfg-system-4d5862053ef2f99d09507b2e9b702aca1229099a.zip
* run start-up script vyatta-config-reboot-params very early in boot process
This script executes scripts lying in the following directory: /opt/vyatta/bin/sudo-users/check-params-on-reboot.d Scripts in check-params-on-reboot.d are intended for parameters that require a reboot to take effect after they are set/changed. Because of the reboot requirement, underlying value and related config paramter value can become out-of-sync in couple of cases: 1. change parameter value, don't save config, reboot. Underlying value is different than the value in config file. 2. install new image; when new image boots, underlying value is the default Vyatta shipped value not the value in config file. More info: http://bugzilla.vyatta.com/show_bug.cgi?id=6915#c1 This check-in also adds ipv6_disable_blacklist script in check-params-on-reboot.d to fix the above mentioned problem for 'system ipv6 disable' and 'system ipv6 blacklist'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 74784522..0fabe989 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,8 @@ cfgdir = $(datadir)/vyatta-cfg/templates
share_perl5dir = $(datarootdir)/perl5/Vyatta/Login
bin_sudo_usersdir = $(bindir)/sudo-users
curverdir = $(sysconfdir)/config-migrate/current
+checkparamsonrebootdir = $(bindir)/sudo-users/check-params-on-reboot.d
+initddir = /etc/init.d
netplugupdir = /etc/netplug/linkup.d
netplugdowndir = /etc/netplug/linkdown.d
modprobedir = /etc/modprobe.d
@@ -10,6 +12,11 @@ modprobe_DATA = etc/modprobe.d/no-copybreak.conf
bin_SCRIPTS =
sbin_SCRIPTS =
sysconf_DATA =
+initd_SCRIPTS =
+checkparamsonreboot_SCRIPTS =
+
+initd_SCRIPTS += etc/init.d/vyatta-config-reboot-params
+checkparamsonreboot_SCRIPTS += scripts/check-params-on-reboot.d/ipv6_disable_blacklist
netplugup_SCRIPTS = scripts/netplug/linkup/dhclient
netplugdown_SCRIPTS = scripts/netplug/linkdown/dhclient