summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Estabrook <jestabro@vyos.io>2020-12-30 10:17:53 -0600
committerJohn Estabrook <jestabro@vyos.io>2020-12-30 11:56:27 -0600
commit4bc5dabe46fffc2edd5bdbda27f020ed1a2bfc33 (patch)
treee0acaa2bcadcdbbff3569a85a4c9d6631766ff7f /Makefile.am
parent8964d55045f57218d2f05770d9f954e620a81974 (diff)
downloadvyatta-cfg-system-4bc5dabe46fffc2edd5bdbda27f020ed1a2bfc33.tar.gz
vyatta-cfg-system-4bc5dabe46fffc2edd5bdbda27f020ed1a2bfc33.zip
migration: T3161: move XorpConfigParser to vyatta-cfg-system
The scripts: vyatta_net_name vyatta_interface_rescan still require XorpConfigParser; all other uses have been rewritten, or obviated. In order to retire the package vyatta-config-migrate in favor of keeping migration scripts in vyos-1x, we need to move this module into vyatta-cfg-system for use by the above mentioned scripts.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7fbb89b2..68bb7998 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,7 @@ checkparamsonrebootdir = $(bindir)/sudo-users/check-params-on-reboot.d
initddir = /etc/init.d
modprobedir = /etc/modprobe.d
modprobe_DATA = etc/modprobe.d/no-copybreak.conf
+share_perl5dir = $(datadir)/perl5
bin_SCRIPTS =
sbin_SCRIPTS =
@@ -63,6 +64,9 @@ sbin_SCRIPTS += scripts/vyos-persistpath
sbin_PROGRAMS = src/valid_address
sbin_PROGRAMS += src/local_ip
+share_perl5_DATA =
+share_perl5_DATA += scripts/XorpConfigParser.pm
+
src_valid_address = src/valid_address.c
src_local_ip = src/local_ip.c