summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKim Hagen <khagen@multi-development.com>2014-07-22 16:15:49 +0200
committerKim Hagen <khagen@multi-development.com>2014-07-22 16:15:49 +0200
commitc3b390629699257cc7aaedebcad419bd8c9c8bbf (patch)
tree97670a7afc527e3de047528425266c0c2421929c /debian/rules
parent0ff877570c8265f9cfd1ea1488cc9543e49ddcf1 (diff)
downloadvyatta-cfg-system-c3b390629699257cc7aaedebcad419bd8c9c8bbf.tar.gz
vyatta-cfg-system-c3b390629699257cc7aaedebcad419bd8c9c8bbf.zip
Only depend on grub if archtecture is i386 or amd64
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 10 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 0ae83713..96038c44 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,6 +28,14 @@ configure += --infodir=\$${prefix}/share/info
configure += CFLAGS="$(CFLAGS)"
configure += LDFLAGS="-Wl,-z,defs"
+ifeq ($(shell dpkg --print-architecture),i386)
+ SUBSTVARS = -Varch:Depends="grub-pc (>= 1.98+20100804)"
+endif
+
+ifeq ($(shell dpkg --print-architecture),amd64)
+ SUBSTVARS = -Varch:Depends="grub-pc (>= 1.98+20100804)"
+endif
+
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
@@ -89,9 +97,9 @@ binary-indep: build install
dh_fixperms
dh_installdeb
if [ -f "../.VYATTA_DEV_BUILD" ]; then \
- dh_gencontrol -- -v999.dev; \
+ dh_gencontrol -- -v999.dev $(SUBSTVARS); \
else \
- dh_gencontrol; \
+ dh_gencontrol $(SUBSTVARS); \
fi
dh_md5sums
dh_builddeb