summaryrefslogtreecommitdiff
path: root/templates/interfaces/tunnel/node.def
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-06-01 16:06:33 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-06-01 16:06:33 -0700
commite9bec39ea6198e36745255a1853fe03f9a65a727 (patch)
treea2730e4e6ecf9a17a5cc654529714bc1e7b1320c /templates/interfaces/tunnel/node.def
parent15d9e99bae90169cce6da359cb45d5cda7076b71 (diff)
parent19a38fe4d18f05d69b97c6785d5ef752479db7bb (diff)
downloadvyatta-cfg-system-e9bec39ea6198e36745255a1853fe03f9a65a727.tar.gz
vyatta-cfg-system-e9bec39ea6198e36745255a1853fe03f9a65a727.zip
Merge branch 'jenner' into kenwood
Conflicts: debian/changelog
Diffstat (limited to 'templates/interfaces/tunnel/node.def')
-rw-r--r--templates/interfaces/tunnel/node.def7
1 files changed, 5 insertions, 2 deletions
diff --git a/templates/interfaces/tunnel/node.def b/templates/interfaces/tunnel/node.def
index 68302461..77aaa5fa 100644
--- a/templates/interfaces/tunnel/node.def
+++ b/templates/interfaces/tunnel/node.def
@@ -16,11 +16,14 @@ create:expression: "\
if [ -n \"$VAR(./key/@)\" ]; then \
KEY=\"key $VAR(./key/@)\"; \
fi; \
- MC=\"multicast $VAR(./multicast/@) allmulticast $VAR(./multicast/@)\"; \
+ if [ x$VAR(./multicast/@) == xenable ]; then \
+ MC=\"multicast on allmulticast on\"; \
+ fi; \
sudo ip tunnel add $VAR(@) \
local $VAR(./local-ip/@) remote $VAR(./remote-ip/@) \
mode $VAR(./encapsulation/@) $KEY; \
- sudo ip link set $VAR(@) $MC up;" ; "Error creating $VAR(@)"
+ sudo ip link set $VAR(@) $MC up;" ; \
+ "Error creating $VAR(@)"
delete:expression: "sudo ip tunnel del $VAR(@)" ; "Error deleting $VAR(@)"