summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog18
-rwxr-xr-xscripts/keepalived/vyatta-keepalived.pl4
-rw-r--r--templates/interfaces/bonding/node.tag/vif/node.tag/vrrp/vrrp-group/node.tag/interface/node.def1
-rw-r--r--templates/interfaces/bonding/node.tag/vrrp/vrrp-group/node.tag/interface/node.def1
4 files changed, 23 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 40916f0b..0ad2c1b5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,21 @@
+vyatta-cfg-system (0.19.130) unstable; urgency=low
+
+ * Support VRRP virtual MAC interfaces above bond and bond vif
+ interfaces
+
+ -- Bob Gilligan <gilligan@vyatta.com> Mon, 28 Nov 2011 15:41:39 -0800
+
+vyatta-cfg-system (0.19.129) unstable; urgency=low
+
+ [ Stephen Hemminger ]
+ * Remove unnecessary sudo on ethtool
+ * Fix perl deprecated warning with 5.14
+
+ [ Bob Gilligan ]
+ * Use new naming convention for VRRP virtual mac interfaces.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Mon, 28 Nov 2011 15:15:13 -0800
+
vyatta-cfg-system (0.19.128) unstable; urgency=low
* Fix dyndns failure caused by commit:
diff --git a/scripts/keepalived/vyatta-keepalived.pl b/scripts/keepalived/vyatta-keepalived.pl
index e834745b..f419ac41 100755
--- a/scripts/keepalived/vyatta-keepalived.pl
+++ b/scripts/keepalived/vyatta-keepalived.pl
@@ -247,7 +247,9 @@ sub keepalived_get_values {
$output .= "\tinterface $intf\n";
$output .= "\tvirtual_router_id $group\n";
if ($use_vmac) {
- $output .= "\tuse_vmac\n";
+ $output .= "\tuse_vmac $intf";
+ $output .= "v";
+ $output .= "$group\n";
}
$output .= "\tpriority $priority\n";
if ( $preempt eq "false" ) {
diff --git a/templates/interfaces/bonding/node.tag/vif/node.tag/vrrp/vrrp-group/node.tag/interface/node.def b/templates/interfaces/bonding/node.tag/vif/node.tag/vrrp/vrrp-group/node.tag/interface/node.def
new file mode 100644
index 00000000..03f22d28
--- /dev/null
+++ b/templates/interfaces/bonding/node.tag/vif/node.tag/vrrp/vrrp-group/node.tag/interface/node.def
@@ -0,0 +1 @@
+help: Configure a virtual MAC interface
diff --git a/templates/interfaces/bonding/node.tag/vrrp/vrrp-group/node.tag/interface/node.def b/templates/interfaces/bonding/node.tag/vrrp/vrrp-group/node.tag/interface/node.def
new file mode 100644
index 00000000..03f22d28
--- /dev/null
+++ b/templates/interfaces/bonding/node.tag/vrrp/vrrp-group/node.tag/interface/node.def
@@ -0,0 +1 @@
+help: Configure a virtual MAC interface