summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xscripts/install/install-get-partition2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 939f3a27..65035ba8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg-system (0.17.2) unstable; urgency=low
+
+ * Bugfix 5327: Don't try to save config from images with none.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Tue, 16 Feb 2010 11:57:24 -0800
+
vyatta-cfg-system (0.17.1) unstable; urgency=low
* use more specific version before which modprobe files in vyatta-cfg
diff --git a/scripts/install/install-get-partition b/scripts/install/install-get-partition
index 37ec5580..f6977850 100755
--- a/scripts/install/install-get-partition
+++ b/scripts/install/install-get-partition
@@ -549,7 +549,7 @@ save_old_info() {
image_dirs=/mnt/tmp/boot/*
for dir in $image_dirs; do
- if [ -f $dir/live-rw/opt/vyatta/etc/config/.vyatta_config ]; then
+ if [ -f $dir/live-rw/config/.vyatta_config ]; then
item=${dir##/mnt/tmp/boot/}
images=($item ${images[@]})