summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rwxr-xr-xscripts/install/install-image4
-rwxr-xr-xscripts/keepalived/vyatta-show-vrrp.pl10
3 files changed, 25 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 1fa67159..95ab609e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+vyatta-cfg-system (0.19.140) unstable; urgency=low
+
+ * Fix up formating of Vyatta specific HTTP options.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Tue, 06 Dec 2011 14:05:59 -0800
+
+vyatta-cfg-system (0.19.139) unstable; urgency=low
+
+ * Add parsing of vrrp interfaces so that 'show vrrp interfaces <vmac-
+ interface>' will do what the user intended.
+
+ -- John Southworth <john.southworth@vyatta.com> Tue, 06 Dec 2011 11:50:17 -0800
+
vyatta-cfg-system (0.19.138) unstable; urgency=low
* make vyatta-interfaces.pl aware of vrrp interfaces
diff --git a/scripts/install/install-image b/scripts/install/install-image
index ea8cfd7f..b5061b26 100755
--- a/scripts/install/install-image
+++ b/scripts/install/install-image
@@ -62,9 +62,9 @@ fetch_iso_by_url ()
auth=""
fi
- client_hdr="-H vyatta-client: install-image"
+ client_hdr="-HVyatta-Client: install-image"
vyatta_version=`dpkg-query --showformat='${Version}' --show vyatta-version`
- vers_hdr="-H vyatta-version: $vyatta_version"
+ vers_hdr="-HVyatta-Version: $vyatta_version"
filename="${TEMP_DIR}/${NEW_ISO##*/}"
curl "$client_hdr" "$vers_hdr" $auth -f -o $filename $NEW_ISO
diff --git a/scripts/keepalived/vyatta-show-vrrp.pl b/scripts/keepalived/vyatta-show-vrrp.pl
index 818d5e40..ecf2bf75 100755
--- a/scripts/keepalived/vyatta-show-vrrp.pl
+++ b/scripts/keepalived/vyatta-show-vrrp.pl
@@ -301,6 +301,16 @@ if ($showsummary == 1) {
}
foreach my $intf (@intfs) {
+ my $intf_vrid;
+ if ($intf =~ m/(\w+)\.(\d+)v(\d+)/){
+ $intf = "$1.$2";
+ $intf_vrid = $3;
+ } elsif ($intf =~ m/(\w+)v(\d+)/){
+ $intf = $1;
+ $intf_vrid = $2;
+ }
+ next if ($group ne 'all' && $intf_vrid && $intf_vrid != $group);
+ $group = $intf_vrid if ($group eq 'all' && $intf_vrid);
my @state_files = Vyatta::Keepalived::get_state_files($intf, $group);
foreach my $state_file (@state_files) {
&$display_func($state_file);