summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xscripts/keepalived/vyatta-keepalived.pl2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ae385e85..bf8522f8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+vyatta-cfg-system (0.19.153) unstable; urgency=low
+
+ * Bugfix 7689: change vrrp auth_type detection 'simple' to 'plaintext-
+ password'
+
+ -- John Southworth <john.southworth@vyatta.com> Tue, 03 Jan 2012 16:46:02 -0800
+
vyatta-cfg-system (0.19.152) unstable; urgency=low
* bonding: do not allow interface with VRRP to be enslaved
diff --git a/scripts/keepalived/vyatta-keepalived.pl b/scripts/keepalived/vyatta-keepalived.pl
index 5c7676ea..3911588a 100755
--- a/scripts/keepalived/vyatta-keepalived.pl
+++ b/scripts/keepalived/vyatta-keepalived.pl
@@ -216,7 +216,7 @@ sub keepalived_get_values {
$auth_type = $config->returnValue("type");
$auth_pass = $config->returnValue("password");
if ( defined $auth_type ) {
- $auth_type = "PASS" if $auth_type eq "simple";
+ $auth_type = "PASS" if $auth_type eq "plaintext-password";
$auth_type = uc($auth_type);
if ( !defined $auth_pass ) {
next if $noerr;