summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xscripts/system/vyatta_update_logrotate.pl1
-rw-r--r--templates/system/syslog/node.def2
3 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4fff3633..55a713d2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg-system (0.20.28) unstable; urgency=low
+
+ * Configure logrotate to maintain log file ownership
+
+ -- James Davidson <james.davidson@vyatta.com> Tue, 04 Sep 2012 18:31:25 -0700
+
vyatta-cfg-system (0.20.27) unstable; urgency=low
* Bugfix 6967: Test if an address is already applied to an interface
diff --git a/scripts/system/vyatta_update_logrotate.pl b/scripts/system/vyatta_update_logrotate.pl
index 05867658..8620ede1 100755
--- a/scripts/system/vyatta_update_logrotate.pl
+++ b/scripts/system/vyatta_update_logrotate.pl
@@ -40,6 +40,7 @@ if ($set == 1) {
$log_file {
missingok
notifempty
+ create
rotate $files
size=${size}k
}
diff --git a/templates/system/syslog/node.def b/templates/system/syslog/node.def
index ebe02232..81fb3f6c 100644
--- a/templates/system/syslog/node.def
+++ b/templates/system/syslog/node.def
@@ -1,5 +1,5 @@
priority: 400
help: System logging daemon
end: if /opt/vyatta/sbin/vyatta_update_syslog.pl; then
- sudo /usr/sbin/invoke-rc.d rsyslog reload || sudo /usr/sbin/invoke-rc.d rsyslog restart
+ sudo /usr/sbin/invoke-rc.d rsyslog restart
fi