summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog19
-rw-r--r--templates/interfaces/ethernet/node.tag/bond-group/node.def2
-rw-r--r--templates/interfaces/ethernet/node.tag/bridge-group/node.def2
-rw-r--r--templates/interfaces/ethernet/node.tag/vif/node.tag/bridge-group/node.def2
4 files changed, 22 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index c4c1a0aa..679ed013 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,22 @@
+vyatta-cfg-system (0.15.97) unstable; urgency=low
+
+ * Fix 5063: committing "set interfaces ethernet <> bridge-group bridge
+ <>" got "invalid variable reference (invalid format)"
+
+ -- Stig Thormodsrud <stig@vyatta.com> Mon, 02 Nov 2009 18:31:22 -0800
+
+vyatta-cfg-system (0.15.96) unstable; urgency=low
+
+ [ An-Cheng Huang ]
+ * use top-level pid for progress indicator
+
+ [ Stephen Hemminger ]
+ * Don't want/need --package option to pam-auth-update
+ * Reset PAM configuration on boot
+ * rename pam-radius to pam_radius.cfg
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Mon, 02 Nov 2009 17:28:17 -0800
+
vyatta-cfg-system (0.15.95) unstable; urgency=low
[ David S. Madole ]
diff --git a/templates/interfaces/ethernet/node.tag/bond-group/node.def b/templates/interfaces/ethernet/node.tag/bond-group/node.def
index 7b6df036..c173ae3f 100644
--- a/templates/interfaces/ethernet/node.tag/bond-group/node.def
+++ b/templates/interfaces/ethernet/node.tag/bond-group/node.def
@@ -6,7 +6,7 @@ commit:expression: exec \
allowed: ${vyatta_sbindir}/vyatta-interfaces.pl --show=bonding
-update: OLDG=`${vyatta_sbindir}/vyatta-cli-expand-var.pl \$\(/interfaces/ethernet/$VAR(../@)/bond-group/@\)`
+update: OLDG=`${vyatta_sbindir}/vyatta-cli-expand-var.pl \\$VAR\(/interfaces/ethernet/$VAR(../@)/bond-group/@\)`
if [ -n "$OLDG" ]; then
sudo ${vyatta_sbindir}/vyatta-bonding.pl --dev=$OLDG --remove=$VAR(../@)
fi
diff --git a/templates/interfaces/ethernet/node.tag/bridge-group/node.def b/templates/interfaces/ethernet/node.tag/bridge-group/node.def
index 5ea9da19..b30a9e10 100644
--- a/templates/interfaces/ethernet/node.tag/bridge-group/node.def
+++ b/templates/interfaces/ethernet/node.tag/bridge-group/node.def
@@ -2,7 +2,7 @@ help: Add this interface to a bridge group
end:
ethif=$VAR(../@)
- oldbridge=`/opt/vyatta/sbin/vyatta-cli-expand-var.pl \$\(/interfaces/ethernet/$ethif/bridge-group/bridge/@\)`
+ oldbridge=`/opt/vyatta/sbin/vyatta-cli-expand-var.pl \\$VAR\(/interfaces/ethernet/$ethif/bridge-group/bridge/@\)`
newbridge="$VAR(./bridge/@)"
if [ ${COMMIT_ACTION} = 'SET' ]; then
diff --git a/templates/interfaces/ethernet/node.tag/vif/node.tag/bridge-group/node.def b/templates/interfaces/ethernet/node.tag/vif/node.tag/bridge-group/node.def
index 0bade03a..e3645b1c 100644
--- a/templates/interfaces/ethernet/node.tag/vif/node.tag/bridge-group/node.def
+++ b/templates/interfaces/ethernet/node.tag/vif/node.tag/bridge-group/node.def
@@ -5,7 +5,7 @@ end:
eth=$VAR(../../@)
vif=$VAR(../@)
ethif=$eth.$vif
- oldbridge=`/opt/vyatta/sbin/vyatta-cli-expand-var.pl \$\(/interfaces/ethernet/$eth/vif/$vif/bridge-group/bridge/@\)`
+ oldbridge=`/opt/vyatta/sbin/vyatta-cli-expand-var.pl \\$VAR\(/interfaces/ethernet/$eth/vif/$vif/bridge-group/bridge/@\)`
newbridge="$VAR(./bridge/@)"
if [ ${COMMIT_ACTION} = 'SET' ]; then