summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rwxr-xr-xscripts/system/vyatta_update_resolv.pl3
2 files changed, 13 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 64afb1c4..14a371a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+vyatta-cfg-system (0.17.106) unstable; urgency=low
+
+ * use new error reference location method
+
+ -- root <root@vyatta-build> Fri, 08 Oct 2010 12:13:11 -0700
+
+vyatta-cfg-system (0.17.105) unstable; urgency=low
+
+ * Convert from syslog to rsyslog
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Fri, 08 Oct 2010 17:12:41 -0700
+
vyatta-cfg-system (0.17.104) unstable; urgency=low
[ Stephen Hemminger ]
diff --git a/scripts/system/vyatta_update_resolv.pl b/scripts/system/vyatta_update_resolv.pl
index 041292be..6897c791 100755
--- a/scripts/system/vyatta_update_resolv.pl
+++ b/scripts/system/vyatta_update_resolv.pl
@@ -47,8 +47,7 @@ if ($dhclient_script == 1) {
}
if ($dhclient_script == 0 && @domains > 0 && $domain_name && length($domain_name) > 0) {
- print STDERR "System configuration error. Both \'domain-name\' and \'domain-search\' are specified, but only one of these mutually exclusive parameters is allowed.\n";
- print STDERR "System configuration commit aborted due to error(s).\n";
+ $vc->outputError(["system domain-name","system domain-search domain"],"System configuration error. Both \'domain-name\' and \'domain-search\' are specified, but only one of these mutually exclusive parameters is allowed.");
exit(1);
}