summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xscripts/snmp/vyatta-snmp-v3.pl2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 064d3a26..b6c549f4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg-system (0.20.62) unstable; urgency=low
+
+ * Replace original config file handling behaviour
+
+ -- James Davidson <james.davidson@vyatta.com> Wed, 17 Apr 2013 10:54:02 -0700
+
vyatta-cfg-system (0.20.61) unstable; urgency=low
* Bugfix 8711: Switch to Bash syntax for conditionals
diff --git a/scripts/snmp/vyatta-snmp-v3.pl b/scripts/snmp/vyatta-snmp-v3.pl
index 2bf9b582..5391a85f 100755
--- a/scripts/snmp/vyatta-snmp-v3.pl
+++ b/scripts/snmp/vyatta-snmp-v3.pl
@@ -54,7 +54,7 @@ sub randhex {
sub parse_config_file {
open( my $cfg, '<', $vyatta_config_file )
- or die "Can't open: $vyatta_config_file: $!";
+ or return;
while (<$cfg>) {
chomp; # no newline
s/#.*//; # no comments