summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStig Thormodsrud <stig@vyatta.com>2007-12-19 18:09:06 -0800
committerStig Thormodsrud <stig@vyatta.com>2007-12-19 18:09:06 -0800
commit2b188e0c9ca392a7c54f4169378e523c355873c1 (patch)
tree0ac0524531ab4033af0da006cf39f8736b52beed /Makefile.am
downloadvyatta-cfg-vpn-2b188e0c9ca392a7c54f4169378e523c355873c1.tar.gz
vyatta-cfg-vpn-2b188e0c9ca392a7c54f4169378e523c355873c1.zip
Port vpn cfg from fairfield to glendale.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..b2e9fd6
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+cfgdir = $(datadir)/vyatta-cfg/templates
+share_perl5dir = $(datarootdir)/perl5
+libudevdir = /lib/udev
+etcudevdir = /etc/udev
+initddir = /etc/init.d
+
+bin_SCRIPTS =
+sbin_SCRIPTS =
+sysconf_DATA =
+
+sbin_SCRIPTS += scripts/vpn-config.pl
+
+share_perl5_DATA = scripts/VyattaVPNUtil.pm
+
+
+cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
+ cpio -0pd
+
+install-exec-hook:
+ mkdir -p $(DESTDIR)$(cfgdir)
+ cd templates; $(cpiop) $(DESTDIR)$(cfgdir)
+