summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSaurabh Mohan <saurabh.mohan@vyatta.com>2012-08-13 14:42:58 -0700
committerSaurabh Mohan <saurabh.mohan@vyatta.com>2012-08-13 14:42:58 -0700
commit4d28253c3273473674a578396396a449a186b68c (patch)
tree315a348fcdaafd3c0782ac65e55ce65ffc9c5abd /debian/rules
parenta25954fd108a5991e51803efd27ca470e3a1cb67 (diff)
downloadvyatta-cfg-vpn-4d28253c3273473674a578396396a449a186b68c.tar.gz
vyatta-cfg-vpn-4d28253c3273473674a578396396a449a186b68c.zip
Bugfix 8276: Vti not working on a 32-bit machine due to sign bit overload.
In a 32-bit machine the signed bit is at the 32'nd bit position. Mark used by vti set's (0x9000-0000) that bit position. Changed the api to use strtoul to read the data from the command line and configure the mark. Also, changed the vyatta-cfg-vpn package to be arch dependent since it now has a binary that it generates.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 9b0e96d..dde505a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -74,8 +74,8 @@ install: build
install -D --mode=0644 debian/lintian $(PKGDIR)/usr/share/lintian/overrides/$(PACKAGE)
-# Build architecture-independent files here.
-binary-indep: build install
+# Build architecture-dependent files here.
+binary-arch: build install
rm -f debian/files
dh_testdir
dh_testroot
@@ -96,9 +96,9 @@ binary-indep: build install
dh_md5sums
dh_builddeb
-# Build architecture-dependent files here.
-binary-arch: build install
-# This is an architecture independent package
+# Build architecture-independent files here.
+binary-indep: build install
+# This is an architecture dependent package
# so; we have nothing to do by default.
binary: binary-indep binary-arch