summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-02-19 09:48:43 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-02-19 09:48:43 -0800
commit634520511cc1aeda7eea16425204e2d087eb7ad7 (patch)
tree71fabe874be6ceead476b8b5dbcb31b7c1fca5ea
parent4f427171c08f02455c8252baf8f86d9db0a1a5b3 (diff)
parent103278dd9c2fe4a0ec0c31b81b75905205651c91 (diff)
downloadvyatta-cfg-634520511cc1aeda7eea16425204e2d087eb7ad7.tar.gz
vyatta-cfg-634520511cc1aeda7eea16425204e2d087eb7ad7.zip
Merge branch 'jenner' of suva.vyatta.com:/git/vyatta-cfg into jenner
-rw-r--r--debian/changelog21
-rwxr-xr-xetc/bash_completion.d/20vyatta-cfg11
2 files changed, 32 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3428d35..37cd877 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,24 @@
+vyatta-cfg (0.14.19) unstable; urgency=low
+
+ * fix for bug 4138: reset *glob after completion
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Wed, 18 Feb 2009 16:58:03 -0800
+
+vyatta-cfg (0.14.18) unstable; urgency=low
+
+ [ slioch ]
+ * need to add service to priority file.
+
+ [ Bob Gilligan ]
+ * Add type check function for firewall IPv6 src/dst address parameters
+
+ [ Stephen Hemminger ]
+ * Remove no longer used protocol/disable entries
+
+ [ Bob Gilligan ]
+
+ -- Bob Gilligan <gilligan@vyatta.com> Wed, 18 Feb 2009 16:52:03 -0800
+
vyatta-cfg (0.14.17) unstable; urgency=low
[ slioch ]
diff --git a/etc/bash_completion.d/20vyatta-cfg b/etc/bash_completion.d/20vyatta-cfg
index 5589d69..515ad18 100755
--- a/etc/bash_completion.d/20vyatta-cfg
+++ b/etc/bash_completion.d/20vyatta-cfg
@@ -823,6 +823,7 @@ vyatta_config_complete ()
generate_pipe_help
vyatta_completions=( "${_vyatta_pipe_completions[@]}" )
vyatta_do_complete
+ eval $restore_shopts
return
fi
@@ -863,6 +864,7 @@ vyatta_config_complete ()
generate_help_text hitems hstrs
vyatta_completions=( "${hitems[@]}" )
vyatta_do_complete
+ eval $restore_shopts
return
fi
@@ -886,6 +888,7 @@ vyatta_config_complete ()
if [ "$command" == "exit" ]; then
if (( num_comp > 1 || ( end_space && num_comp > 0 ) )); then
COMPREPLY=()
+ eval $restore_shopts
return
fi
declare -a hitems=( "discard" )
@@ -893,6 +896,7 @@ vyatta_config_complete ()
generate_help_text hitems hstrs
vyatta_completions=( "discard" )
vyatta_do_complete
+ eval $restore_shopts
return
fi
@@ -950,6 +954,7 @@ vyatta_config_complete ()
if (( idx < last_idx || ( idx == last_idx && end_space ) )); then
# TODO error message?
COMPREPLY=()
+ eval $restore_shopts
return
fi
@@ -987,6 +992,7 @@ vyatta_config_complete ()
fi
vyatta_completions=( "${fmatches[@]}" )
vyatta_do_complete
+ eval $restore_shopts
return
fi
@@ -1007,8 +1013,10 @@ vyatta_config_complete ()
get_tmpl_subdir_help $_tpath matches
vyatta_completions=( "${matches[@]}" )
vyatta_do_complete
+ eval $restore_shopts
return
fi
+ eval $restore_shopts
return
fi
@@ -1025,6 +1033,7 @@ vyatta_config_complete ()
get_node_value_help $_tpath fmatches
vyatta_completions=( "${fmatches[@]}" )
vyatta_do_complete
+ eval $restore_shopts
return
fi
@@ -1067,6 +1076,7 @@ vyatta_config_complete ()
fi
vyatta_completions=( "${matches[@]}" )
vyatta_do_complete
+ eval $restore_shopts
return
fi
@@ -1081,6 +1091,7 @@ vyatta_config_complete ()
get_tmpl_subdir_help $_tpath fmatches
vyatta_completions=( "${fmatches[@]}" )
vyatta_do_complete
+ eval $restore_shopts
return
fi