summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Balocca <rbalocca@vyatta.com>2008-08-03 14:25:43 -0700
committerRick Balocca <rbalocca@vyatta.com>2008-08-03 14:25:43 -0700
commit948bdcbcf4d7c04944bc4212204e97309b5fe499 (patch)
tree136b7cef869c1b129a010afebb2ce83940cfc4b9
parent5cfca8801a52bf8e9421417f82a4cee6cfe8653e (diff)
parent2d83fb22c6921b73d2fa2c0585706887b23cc21f (diff)
downloadvyatta-cfg-948bdcbcf4d7c04944bc4212204e97309b5fe499.tar.gz
vyatta-cfg-948bdcbcf4d7c04944bc4212204e97309b5fe499.zip
Merge branch 'hollywood'
-rw-r--r--debian/changelog73
-rw-r--r--scripts/vyatta-interfaces.pl8
2 files changed, 79 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index bced47f..ac83ded 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,76 @@
+vyatta-cfg (0.12) unstable; urgency=low
+
+ 3.1.2
+ [ Mark O'Brien ]
+
+
+ [ Rick Balocca ]
+ * Code moved for fix of bug
+ http://bugzilla.vyatta.com/show_bug.cgi?id=3417
+
+ [ Stig Thormodsrud ]
+ * Prioritize vpn ahead of pppo[ea] interfaces.
+
+ [ Mohit Mehta ]
+ * removing code to update resolv.conf from here, it is better to call
+ it from dhclient-script
+ * => Modified VyattaConfig.pm function 'returnOrigValues()' to return
+ empty array when no value is configured
+
+ [ Michael Larson ]
+ * fix for bug 3441. Selective stripping of the 'def' only needs to
+ occur in one location.
+ * Revert "fix for bug 3441. Removed def from listOutputNodes(), which
+ allowed other code that filters out def file to be removed."
+
+ [ root ]
+ * fix for bug 3441. Removed def from listOutputNodes(), which allowed
+ other code that filters out def file to be removed.
+
+ [ rbalocca ]
+ * Fix for bug http://bugzilla.vyatta.com/show_bug.cgi?id=3427
+
+ [ An-Cheng Huang ]
+ * fix for bug 3323: skip deletions of nodes with default values when
+ loading
+
+ [ Michael Larson ]
+ * fix for bug 3216. added no escape option to push path for
+ environmental path variable. note this is appied to all c code
+ access to the
+
+ [ Stig Thormodsrud ]
+ * Partial fix for 3383: check for vyatta-config-version, warn/prompt
+ that it appears to be invalid config.
+
+ [ Michael Larson ]
+ * fix for bug 3377.
+
+ [ An-Cheng Huang ]
+ * fix for bug 3403: allocate correct amount of memory for multi-valued
+ nodes.
+
+ [ Michael Larson ]
+ * Revert "set load-balancing load order after interfaces are
+ configured on load."
+
+ [ Stig Thormodsrud ]
+ * Fix 3396: "commit failed at rank 800" while booting with bgp peer-
+ group.
+
+ [ An-Cheng Huang ]
+ * add help string for "copy" and "rename"
+
+ [ Michael Larson ]
+ * fix for bug 3400. user vyatta needed modification to discard
+ command.
+ * set load-balancing load order after interfaces are configured on
+ load.
+
+ [ Mark O'Brien ]
+
+ -- Mark O'Brien <mobrien@firebolt.vyatta.com> Wed, 23 Jul 2008 21:36:00 -0700
+
vyatta-cfg (0.11) unstable; urgency=low
3.1.1
diff --git a/scripts/vyatta-interfaces.pl b/scripts/vyatta-interfaces.pl
index 18fbf61..3794769 100644
--- a/scripts/vyatta-interfaces.pl
+++ b/scripts/vyatta-interfaces.pl
@@ -312,7 +312,7 @@ sub delete_eth_addrs {
if ($addr eq "dhcp") {
stop_dhclient($intf);
- system("rm -f /var/lib/dhcp3/dhclient_$intf\_lease; rm -f /var/lib/dhcp3/$intf\; rm -f /var/lib/dhcp3/release_$intf\;");
+ system("rm -f /var/lib/dhcp3/dhclient_$intf\_lease; rm -f /var/lib/dhcp3/$intf\; rm -f /var/run/vyatta/dhclient/dhclient_release_$intf\;");
exit 0;
}
my $version = is_ip_v4_or_v6($addr);
@@ -457,7 +457,8 @@ sub op_dhcp_command {
exit 1;
}
- my $release_file = $dhclient_dir . 'release_' . $intf;
+ my $tmp_dhclient_dir = '/var/run/vyatta/dhclient/';
+ my $release_file = $tmp_dhclient_dir . 'dhclient_release_' . $intf;
if ($op_command eq "dhcp-release") {
if (-e $release_file) {
print "IP address for $intf has already been released.\n";
@@ -465,6 +466,9 @@ sub op_dhcp_command {
} else {
print "Releasing DHCP lease on $intf ...\n";
stop_dhclient($intf);
+ if(! -d $tmp_dhclient_dir ){
+ system ("mkdir $tmp_dhclient_dir\;");
+ }
system ("touch $release_file\;");
exit 0;
}