summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-04-27 08:24:49 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-04-27 08:24:49 -0700
commitaa438a2cc742600adc37b116f431fa7dc4af6828 (patch)
tree01d1ea11d245d725ebd559a0f170ca953dcc02bf
parent8c0697b5b5c1c666f84622f632936c96b78d0efe (diff)
parent5d74ce656b33817550903d3471870a303cb70e6b (diff)
downloadvyatta-cfg-aa438a2cc742600adc37b116f431fa7dc4af6828.tar.gz
vyatta-cfg-aa438a2cc742600adc37b116f431fa7dc4af6828.zip
Merge branch 'jenner' of suva.vyatta.com:/git/vyatta-cfg into jenner
-rw-r--r--debian/changelog10
-rwxr-xr-xlib/Vyatta/Interface.pm5
-rw-r--r--templates/priority10
3 files changed, 20 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index ee2b201..bb493b8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+vyatta-cfg (0.14.68) unstable; urgency=low
+
+ [ Stephen Hemminger ]
+ * Add support for virtual-ethernets
+
+ [ Stig Thormodsrud ]
+ * Add more firewall priorities.
+
+ -- Stig Thormodsrud <stig@vyatta.com> Sun, 26 Apr 2009 19:02:45 -0700
+
vyatta-cfg (0.14.67) unstable; urgency=low
[ Stephen Hemminger ]
diff --git a/lib/Vyatta/Interface.pm b/lib/Vyatta/Interface.pm
index 50122b4..b2a0041 100755
--- a/lib/Vyatta/Interface.pm
+++ b/lib/Vyatta/Interface.pm
@@ -51,6 +51,10 @@ use constant {
IFF_ECHO => 0x40000, # echo sent packets
};
+#
+# Mapping from name to attributes
+# path: configuration level below interfaces
+# vif: places to look for vif (if any)
my %net_prefix = (
'adsl[\d]+' => { path => 'adsl',
vif => 'vif', },
@@ -70,6 +74,7 @@ my %net_prefix = (
},
'tun[\d]+' => { path => 'tunnel' },
'wlm[\d]+' => { path => 'wireless-modem' },
+ 'veth[\d]+' => { path => 'ethernet', vif => 'vif', },
);
# get list of interface types
diff --git a/templates/priority b/templates/priority
index c6e929d..64d2658 100644
--- a/templates/priority
+++ b/templates/priority
@@ -86,11 +86,11 @@
#
200 firewall/group
-210 firewall/name
-210 firewall/modify
-210 firewall/ipv6-name
-210 firewall/ipv6-modify
-210 firewall
+210 firewall/name/node.tag
+210 firewall/modify/node.tag
+210 firewall/ipv6-name/node.tag
+210 firewall/ipv6-modify/node.tag
+215 firewall
300 protocols/ospf
301 protocols/ospfv3
302 protocols/rip